# CVE-2026-33524: Zserio: Integer Overflow in BitStreamReader and Unbounded Memory Allocation in Deserialization

> A crafted payload triggers an integer overflow leading to unbounded memory allocation and process crash in the Zserio library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Apr 2026
- **Updated:** 27 Apr 2026
- **Also known as:** GHSA-cwq5-8pvq-j65j

## What is CVE-2026-33524?

CVE-2026-33524 is a high-severity vulnerability in ndsev zserio, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Zserio is a framework for serializing structured data with a compact and efficient way with low overhead. Prior to 2.18.1, a crafted payload as small as 4-5 bytes can force memory allocations of up to 16 GB, crashing any process with an OOM error (Denial of Service). This vulnerability is fixed in 2.18.1.

Weakness: CWE-789 (Memory Allocation with Excessive Size Value)

## Which versions are affected by CVE-2026-33524?

2 open source packages ship an affected version, including io.github.ndsev:zserio-runtime. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.github.ndsev:zserio-runtime` | Maven | All versions | 2.18.1 |
| `io.github.ndsev:zserio-runtime` | Maven | All versions | 2.18.1 |

Products: Nds-Association Zserio.

## How do I fix CVE-2026-33524?

Upgrade io.github.ndsev:zserio-runtime to 2.18.1 or later.

## Is CVE-2026-33524 being exploited?

There is no known exploitation of CVE-2026-33524 in the wild and no public exploit code.

## Other vulnerabilities in ndsev zserio

- [CVE-2026-33666](https://insights.sbomify.com/CVE-2026-33666/): Zserio: Integer Overflow in BitStreamReader on 32-bit platforms (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33524 and fix it if it is affected.

What it is: CVE-2026-33524 is a high-severity vulnerability in ndsev zserio, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33524 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.github.ndsev:zserio-runtime (Maven): affected all versions; fixed in 2.18.1
- io.github.ndsev:zserio-runtime (Maven): affected all versions; fixed in 2.18.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33524/ (Markdown: https://insights.sbomify.com/CVE-2026-33524/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33524
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33524
- OSV: https://osv.dev/vulnerability/CVE-2026-33524

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33524/
Summaries are generated and may contain mistakes; the official description above is the record.
