{"answers":{"affected":"4 open source packages ship an affected version, including github.com/authelia/authelia/v4 and github.com/authelia/authelia. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-33525 in the wild and no public exploit code.","fix":"Upgrade github.com/authelia/authelia/v4 to 4.39.16 or later.","what":"CVE-2026-33525 is a low-severity cross-site scripting vulnerability in authelia, published on 26 Mar 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-33525 and fix it if it is affected.\n\nWhat it is: CVE-2026-33525 is a low-severity cross-site scripting vulnerability in authelia, published on 26 Mar 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-33525 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/authelia/authelia/v4 (Go): affected from 4.39.15; fixed in 4.39.16\n- github.com/authelia/authelia/v4 (Go): affected from 4.39.15; fixed in 4.39.16\n- github.com/authelia/authelia/v4 (Go): affected from 4.39.15; fixed in 4.39.16\n- github.com/authelia/authelia (Go): affected all versions; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-33525/ (Markdown: https://insights.sbomify.com/CVE-2026-33525/index.md)","id":"CVE-2026-33525","markdown":"https://insights.sbomify.com/CVE-2026-33525/index.md","name":"CVE-2026-33525","record":{"aliases":["GHSA-gmfg-3v4q-9qr4","GO-2026-4818"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"Authentication server","requires_auth":"none","summary":"Attackers can inject JavaScript into the login page if Content Security Policy is disabled, potentially leading to session hijacking or code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"authelia","vendor":"authelia"}],"cvss":{"score":0.5,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:A/AC:H/AT:P/PR:N/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N/E:U","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Authelia is an open-source authentication and authorization server providing two-factor authentication and single sign-on (SSO) for applications via a web portal. In version 4.39.15, an attacker may potentially be able to inject javascript into the Authelia login page if several conditions are met simultaneously. Unless both the `script-src` and `connect-src` directives have been modified it's almost impossible for this to have a meaningful impact. However if both of these are and they are done so without consideration to their potential impact; there is a are situations where this vulnerability could be exploited. This is caused to the lack of neutralization of the `langauge` cookie value when rendering the HTML template. This vulnerability is likely difficult to discover though fingerprinting due to the way Authelia is designed but it should not be considered impossible. The additional requirement to identify the secondary application is however likely to be significantly harder to identify along side this, but also likely easier to fingerprint. Users should upgrade to 4.39.16 or downgrade to 4.39.14 to mitigate the issue. The overwhelming majority of installations will not be affected and no workarounds are necessary. The default value for the Content Security Policy makes exploiting this weakness completely impossible. It's only possible via the deliberate removal of the Content Security Policy or deliberate inclusion of clearly noted unsafe policies.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Authelia: Improper Neutralization of Input During Web Page Generation Leads to Potential Cross-site Scripting","id":"CVE-2026-33525","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":4,"n_references":1,"next":{"headline":"Squid vulnerable to Denial of Service in ICP Request handling","id":"CVE-2026-33526"},"packages":[{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":[],"package":"github.com/authelia/authelia","purl":"pkg:golang/github.com/authelia/authelia","source":"GO-2026-4818"},{"ecosystem":"Go","fixed":["4.39.16"],"introduced":["4.39.15"],"last_affected":[],"package":"github.com/authelia/authelia/v4","purl":null,"source":"GHSA-gmfg-3v4q-9qr4"},{"ecosystem":"Go","fixed":["4.39.16"],"introduced":["4.39.15"],"last_affected":[],"package":"github.com/authelia/authelia/v4","purl":"pkg:golang/github.com/authelia/authelia/v4","source":"GHSA-gmfg-3v4q-9qr4"},{"ecosystem":"Go","fixed":["4.39.16"],"introduced":["4.39.15"],"last_affected":[],"package":"github.com/authelia/authelia/v4","purl":"pkg:golang/github.com/authelia/authelia/v4","source":"GO-2026-4818"}],"prev":{"headline":"Zserio: Integer Overflow in BitStreamReader and Unbounded Memory Allocation in Deserialization","id":"CVE-2026-33524"},"products":["authelia"],"published":"2026-03-26","related":[{"cvss_score":10,"headline":"Authentication bypassed with malformed request URI","id":"CVE-2021-32637","kev_date_added":null,"published":"2021-05-28"},{"cvss_score":5.7,"headline":"Authelia allows open redirects on the logout endpoint","id":"CVE-2021-29456","kev_date_added":null,"published":"2021-04-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-30","vendors":["authelia"]},"summary":"Attackers can inject JavaScript into the login page if Content Security Policy is disabled, potentially leading to session hijacking or code execution.","url":"https://insights.sbomify.com/CVE-2026-33525/"}