# CVE-2026-33525: Authelia: Improper Neutralization of Input During Web Page Generation Leads to Potential Cross-site Scripting

> Attackers can inject JavaScript into the login page if Content Security Policy is disabled, potentially leading to session hijacking or code execution.

- **Severity:** Low 0.5 (`CVSS:4.0/AV:A/AC:H/AT:P/PR:N/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Mar 2026
- **Updated:** 30 Mar 2026
- **Also known as:** GHSA-gmfg-3v4q-9qr4, GO-2026-4818

## What is CVE-2026-33525?

CVE-2026-33525 is a low-severity cross-site scripting vulnerability in authelia, published on 26 Mar 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Authelia is an open-source authentication and authorization server providing two-factor authentication and single sign-on (SSO) for applications via a web portal. In version 4.39.15, an attacker may potentially be able to inject javascript into the Authelia login page if several conditions are met simultaneously. Unless both the `script-src` and `connect-src` directives have been modified it's almost impossible for this to have a meaningful impact. However if both of these are and they are done so without consideration to their potential impact; there is a are situations where this vulnerability could be exploited. This is caused to the lack of neutralization of the `langauge` cookie value when rendering the HTML template. This vulnerability is likely difficult to discover though fingerprinting due to the way Authelia is designed but it should not be considered impossible. The additional requirement to identify the secondary application is however likely to be significantly harder to identify along side this, but also likely easier to fingerprint. Users should upgrade to 4.39.16 or downgrade to 4.39.14 to mitigate the issue. The overwhelming majority of installations will not be affected and no workarounds are necessary. The default value for the Content Security Policy makes exploiting this weakness completely impossible. It's only possible via the deliberate removal of the Content Security Policy or deliberate inclusion of clearly noted unsafe policies.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-33525?

4 open source packages ship an affected version, including github.com/authelia/authelia/v4 and github.com/authelia/authelia. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/authelia/authelia/v4` | Go | From 4.39.15 | 4.39.16 |
| `github.com/authelia/authelia/v4` | Go | From 4.39.15 | 4.39.16 |
| `github.com/authelia/authelia/v4` | Go | From 4.39.15 | 4.39.16 |
| `github.com/authelia/authelia` | Go | All versions | None |

Products: Authelia Authelia.

## How do I fix CVE-2026-33525?

Upgrade github.com/authelia/authelia/v4 to 4.39.16 or later.

## Is CVE-2026-33525 being exploited?

There is no known exploitation of CVE-2026-33525 in the wild and no public exploit code.

## Other vulnerabilities in authelia

- [CVE-2021-32637](https://insights.sbomify.com/CVE-2021-32637/): Authentication bypassed with malformed request URI (critical 10.0)
- [CVE-2021-29456](https://insights.sbomify.com/CVE-2021-29456/): Authelia allows open redirects on the logout endpoint (medium 5.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33525 and fix it if it is affected.

What it is: CVE-2026-33525 is a low-severity cross-site scripting vulnerability in authelia, published on 26 Mar 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-33525 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/authelia/authelia/v4 (Go): affected from 4.39.15; fixed in 4.39.16
- github.com/authelia/authelia/v4 (Go): affected from 4.39.15; fixed in 4.39.16
- github.com/authelia/authelia/v4 (Go): affected from 4.39.15; fixed in 4.39.16
- github.com/authelia/authelia (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33525/ (Markdown: https://insights.sbomify.com/CVE-2026-33525/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33525
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33525
- OSV: https://osv.dev/vulnerability/CVE-2026-33525

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33525/
Summaries are generated and may contain mistakes; the official description above is the record.
