# CVE-2026-33529: Zoraxy: Authenticated Path Traversal in Config Import leads to RCE

> An authenticated attacker can exploit a path traversal in the config import endpoint to write arbitrary files, leading to remote code execution.

- **Severity:** Low 3.3 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Mar 2026
- **Updated:** 27 Mar 2026
- **Also known as:** GHSA-7pq3-326h-f8q9, GO-2026-4844

## What is CVE-2026-33529?

CVE-2026-33529 is a low-severity path traversal vulnerability in tobychui zoraxy, published on 26 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Zoraxy is a general purpose HTTP reverse proxy and forwarding tool. Prior to version 3.3.2, an authenticated path traversal vulnerability in the configuration import endpoint allows an authenticated user to write arbitrary files outside the config directory, which can lead to RCE by creating a plugin. Version 3.3.2 patches the issue.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-33529?

3 open source packages ship an affected version, including github.com/tobychui/zoraxy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/tobychui/zoraxy` | Go | All versions | 3.3.2 |
| `github.com/tobychui/zoraxy` | Go | All versions | 3.3.2 |
| `github.com/tobychui/zoraxy` | Go | All versions | 3.3.2+incompatible |

Products: Zoraxy Zoraxy.

## How do I fix CVE-2026-33529?

Upgrade github.com/tobychui/zoraxy to a fixed version for your release line: 3.3.2 or 3.3.2+incompatible.

## Is CVE-2026-33529 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33529 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33529 and fix it if it is affected.

What it is: CVE-2026-33529 is a low-severity path traversal vulnerability in tobychui zoraxy, published on 26 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33529 exists.

Affected packages and fixed versions:
- github.com/tobychui/zoraxy (Go): affected all versions; fixed in 3.3.2
- github.com/tobychui/zoraxy (Go): affected all versions; fixed in 3.3.2
- github.com/tobychui/zoraxy (Go): affected all versions; fixed in 3.3.2+incompatible

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33529/ (Markdown: https://insights.sbomify.com/CVE-2026-33529/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33529
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33529
- OSV: https://osv.dev/vulnerability/CVE-2026-33529

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33529/
Summaries are generated and may contain mistakes; the official description above is the record.
