CVE-2026-33532 yaml is vulnerable to Stack Overflow via deeply nested YAML collections

Medium 4.3 Published Updated

Attackers can crash Node.js applications by supplying deeply nested YAML input, causing a stack overflow in the yaml library.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-33532?

CVE-2026-33532 is a medium-severity denial of service vulnerability in eemeli yaml, published on 26 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

`yaml` is a YAML parser and serialiser for JavaScript. Parsing a YAML document with a version of `yaml` on the 1.x branch prior to 1.10.3 or on the 2.x branch prior to 2.8.3 may throw a RangeError due to a stack overflow. The node resolution/composition phase uses recursive function calls without a depth bound. An attacker who can supply YAML for parsing can trigger a `RangeError: Maximum call stack size exceeded` with a small payload (~2–10 KB). The `RangeError` is not a `YAMLParseError`, so applications that only catch YAML-specific errors will encounter an unexpected exception type. Depending on the host application's exception handling, this can fail requests or terminate the Node.js process. Flow sequences allow deep nesting with minimal bytes (2 bytes per level: one `[` and one `]`). On the default Node.js stack, approximately 1,000–5,000 levels of nesting (2–10 KB input) exhaust the call stack. The exact threshold is environment-dependent (Node.js version, stack size, call stack depth at invocation). Note: the library's `Parser` (CST phase) uses a stack-based iterative approach and is not affected. Only the compose/resolve phase uses actual call-stack recursion. All three public parsing APIs are affected: `YAML.parse()`, `YAML.parseDocument()`, and `YAML.parseAllDocuments()`. Versions 1.10.3 and 2.8.3 contain a patch.

Weakness: CWE-674

Which versions are affected by CVE-2026-33532?

4 open source packages ship an affected version, including yaml. It affects 1 product.

PackageAffectedFixed in
yaml npmFrom 1.0.01.10.3
yaml npmFrom 1.0.01.10.3
yaml npmFrom 2.0.02.8.3
yaml npmFrom 2.0.02.8.3

Products include Eemeli Yaml.

How do I fix CVE-2026-33532?

Upgrade yaml to a fixed version for your release line: 1.10.3 or 2.8.3.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-33532 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33532 exists.

Public exploit code: 1 proofs of concept on GitHub.

Sources

Also known as CLEANSTART-2026-TK29643, CLEANSTART-2026-VC24094, CLSA-2026-1789481683, CLSA-2026-1792490977, CLSA-2026-1792760067, DEBIAN-CVE-2026-33532 and 23 more.

Is CVE-2026-33532 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free