{"answers":{"affected":"4 open source packages ship an affected version, including yaml. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33532 exists.","fix":"Upgrade yaml to a fixed version for your release line: 1.10.3 or 2.8.3.","what":"CVE-2026-33532 is a medium-severity denial of service vulnerability in eemeli yaml, published on 26 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-33532 and fix it if it is affected.\n\nWhat it is: CVE-2026-33532 is a medium-severity denial of service vulnerability in eemeli yaml, published on 26 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33532 exists.\n\nAffected packages and fixed versions:\n- yaml (npm): affected from 1.0.0; fixed in 1.10.3\n- yaml (npm): affected from 1.0.0; fixed in 1.10.3\n- yaml (npm): affected from 2.0.0; fixed in 2.8.3\n- yaml (npm): affected from 2.0.0; fixed in 2.8.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-33532/ (Markdown: https://insights.sbomify.com/CVE-2026-33532/index.md)","id":"CVE-2026-33532","markdown":"https://insights.sbomify.com/CVE-2026-33532/index.md","name":"CVE-2026-33532","record":{"aliases":["CLEANSTART-2026-TK29643","CLEANSTART-2026-VC24094","CLSA-2026-1789481683","CLSA-2026-1792490977","CLSA-2026-1792760067","DEBIAN-CVE-2026-33532","ECHO-b0ef-7a82-29b5","GHSA-48c2-rrv3-qjmp","MINI-224m-pjgh-q94h","MINI-3cg5-2fvv-ffwr","MINI-3r93-7896-49f8","MINI-42q4-xxgf-6vmv","MINI-43qq-97mj-r4vp","MINI-47v2-98mq-m4h5","MINI-7g85-mggh-q958","MINI-7w4r-8f87-7xrp","MINI-7xq4-jpxf-qxxv","MINI-8rw5-v5cc-79x8","MINI-f4v6-2vvj-f3vr","MINI-fvw8-wfvc-p8ch","MINI-g7p5-xq2q-79w2","MINI-mv24-5wj2-f5f5","MINI-p8jj-8r52-4795","MINI-rq5m-g5fc-mf36","MINI-rwf6-mj76-h947","MINI-v99m-5ghp-gx9w","MINI-w9rw-4jpv-f9m4","ROOT-APP-NPM-CVE-2026-33532","UBUNTU-CVE-2026-33532"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript YAML parser","requires_auth":"low_privilege","summary":"Attackers can crash Node.js applications by supplying deeply nested YAML input, causing a stack overflow in the yaml library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"yaml","vendor":"eemeli"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L","version":"3.1"},"cwes":[{"id":"CWE-674","name":"Uncontrolled Recursion"}],"description":"`yaml` is a YAML parser and serialiser for JavaScript. Parsing a YAML document with a version of `yaml` on the 1.x branch prior to 1.10.3 or on the 2.x branch prior to 2.8.3 may throw a RangeError due to a stack overflow. The node resolution/composition phase uses recursive function calls without a depth bound. An attacker who can supply YAML for parsing can trigger a `RangeError: Maximum call stack size exceeded` with a small payload (~2–10 KB). The `RangeError` is not a `YAMLParseError`, so applications that only catch YAML-specific errors will encounter an unexpected exception type. Depending on the host application's exception handling, this can fail requests or terminate the Node.js process. Flow sequences allow deep nesting with minimal bytes (2 bytes per level: one `[` and one `]`). On the default Node.js stack, approximately 1,000–5,000 levels of nesting (2–10 KB input) exhaust the call stack. The exact threshold is environment-dependent (Node.js version, stack size, call stack depth at invocation). Note: the library's `Parser` (CST phase) uses a stack-based iterative approach and is not affected. Only the compose/resolve phase uses actual call-stack recursion. All three public parsing APIs are affected: `YAML.parse()`, `YAML.parseDocument()`, and `YAML.parseAllDocuments()`. Versions 1.10.3 and 2.8.3 contain a patch.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":"2026-03-27","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-03-27T16:13:28Z","kind":"github_poc","ref":"https://github.com/danwulff/astro_CVE-2026-33532","stars":0,"title":null}],"tier":"weaponised"},"has_fix":true,"headline":"yaml is vulnerable to Stack Overflow via deeply nested YAML collections","id":"CVE-2026-33532","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":4,"n_references":4,"next":{"headline":"Glances Vulnerable to Cross-Origin System Information Disclosure via XML-RPC Server CORS Wildcard","id":"CVE-2026-33533"},"packages":[{"ecosystem":"npm","fixed":["1.10.3"],"introduced":["1.0.0"],"last_affected":[],"package":"yaml","purl":null,"source":"GHSA-48c2-rrv3-qjmp"},{"ecosystem":"npm","fixed":["1.10.3"],"introduced":["1.0.0"],"last_affected":[],"package":"yaml","purl":"pkg:npm/yaml","source":"GHSA-48c2-rrv3-qjmp"},{"ecosystem":"npm","fixed":["2.8.3"],"introduced":["2.0.0"],"last_affected":[],"package":"yaml","purl":null,"source":"GHSA-48c2-rrv3-qjmp"},{"ecosystem":"npm","fixed":["2.8.3"],"introduced":["2.0.0"],"last_affected":[],"package":"yaml","purl":"pkg:npm/yaml","source":"GHSA-48c2-rrv3-qjmp"}],"prev":{"headline":"InvenTree has Path Traversal In Report Templates","id":"CVE-2026-33531"},"products":["yaml"],"published":"2026-03-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-03-30","vendors":["eemeli"]},"summary":"Attackers can crash Node.js applications by supplying deeply nested YAML input, causing a stack overflow in the yaml library.","url":"https://insights.sbomify.com/CVE-2026-33532/"}