# CVE-2026-33533: Glances Vulnerable to Cross-Origin System Information Disclosure via XML-RPC Server CORS Wildcard

> An attacker can exfiltrate sensitive system information, including process lists and credentials, via a malicious webpage due to insecure CORS configuration in the XML-RPC server.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Apr 2026
- **Updated:** 2 Apr 2026
- **Also known as:** DEBIAN-CVE-2026-33533, GHSA-7p93-6934-f4q7, PYSEC-2026-2173, UBUNTU-CVE-2026-33533

## What is CVE-2026-33533?

CVE-2026-33533 is a high-severity vulnerability in nicolargo glances, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Glances is an open-source system cross-platform monitoring tool. Prior to version 4.5.3, the Glances XML-RPC server (activated with glances -s or glances --server) sends Access-Control-Allow-Origin: * on every HTTP response. Because the XML-RPC handler does not validate the Content-Type header, an attacker-controlled webpage can issue a CORS "simple request" (POST with Content-Type: text/plain) containing a valid XML-RPC payload. The browser sends the request without a preflight check, the server processes the XML body and returns the full system monitoring dataset, and the wildcard CORS header lets the attacker's JavaScript read the response. The result is complete exfiltration of hostname, OS version, IP addresses, CPU/memory/disk/network stats, and the full process list including command lines (which often contain tokens, passwords, or internal paths). This issue has been patched in version 4.5.3.

Weakness: CWE-942 (Permissive Cross-domain Security Policy with Untrusted Domains)

## Which versions are affected by CVE-2026-33533?

3 open source packages ship an affected version, including glances and Glances. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `glances` | PyPI | All versions | 4.5.3 |
| `glances` | PyPI | All versions | 4.5.3 |
| `Glances` | PyPI | All versions | 4.5.3 |

Products: Nicolargo Glances.

## How do I fix CVE-2026-33533?

Upgrade glances to 4.5.3 or later.

## Is CVE-2026-33533 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33533 exists.

## Other vulnerabilities in nicolargo glances

- [CVE-2026-32633](https://insights.sbomify.com/CVE-2026-32633/): Glances's Browser API Exposes Reusable Downstream Credentials via `/api/4/serverslist` (critical 9.1)
- [CVE-2026-32596](https://insights.sbomify.com/CVE-2026-32596/): Glances exposes the REST API without authentication (high 8.7)
- [CVE-2026-30928](https://insights.sbomify.com/CVE-2026-30928/): Glances Exposes Unauthenticated Configuration Secrets (high 8.7)
- [CVE-2026-32610](https://insights.sbomify.com/CVE-2026-32610/): Glances's Default CORS Configuration Allows Cross-Origin Credential Theft (high 8.1)
- [CVE-2026-32634](https://insights.sbomify.com/CVE-2026-32634/): Glances Central Browser Autodiscovery Leaks Reusable Credentials to Zeroconf-Spoofed Servers (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33533 and fix it if it is affected.

What it is: CVE-2026-33533 is a high-severity vulnerability in nicolargo glances, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33533 exists.

Affected packages and fixed versions:
- glances (PyPI): affected all versions; fixed in 4.5.3
- glances (PyPI): affected all versions; fixed in 4.5.3
- Glances (PyPI): affected all versions; fixed in 4.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33533/ (Markdown: https://insights.sbomify.com/CVE-2026-33533/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33533
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33533
- OSV: https://osv.dev/vulnerability/CVE-2026-33533

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33533/
Summaries are generated and may contain mistakes; the official description above is the record.
