# CVE-2026-33534: EspoCRM has authenticated SSRF via internal-host validation bypass using alternative IPv4 notation

> Authenticated attackers can bypass internal host validation using alternative IPv4 notations to access loopback services and read internal data.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 13 Apr 2026
- **Updated:** 14 Apr 2026
- **Also known as:** GHSA-h7gx-8gwv-7g73

## What is CVE-2026-33534?

CVE-2026-33534 is a medium-severity server-side request forgery vulnerability in espocrm, published on 13 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

EspoCRM is an open source customer relationship management application. Versions 9.3.3 and below have an authenticated Server-Side Request Forgery (SSRF) vulnerability that allows bypassing the internal-host validation logic by using alternative IPv4 representations such as octal notation (e.g., 0177.0.0.1 instead of 127.0.0.1). This is caused by HostCheck::isNotInternalHost() function relying on PHP's filter_var(..., FILTER_VALIDATE_IP), which does not recognize alternative IP formats, causing the validation to fall through to a DNS lookup that returns no records and incorrectly treats the host as safe, however the cURL subsequently normalizes the address and connects to the loopback destination. Through the confirmed /api/v1/Attachment/fromImageUrl endpoint, an authenticated user can force the server to make requests to loopback-only services and store the fetched response as an attachment. This vulnerability is distinct from CVE-2023-46736 (which involved redirect-based SSRF) and may allow access to internal resources reachable from the application runtime. This issue has been fixed in version 9.3.4.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-33534?

It affects 1 product.


Products: Espocrm Espocrm.

## How do I fix CVE-2026-33534?

No fix has been published for CVE-2026-33534 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-33534 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33534 exists.

Public exploit code:

- EspoCRM 9.3.3 - Authenticated SSRF via Alternative IPv4 Notation (github_poc): https://github.com/EntroVyx/CVE-2026-33534
- EspoCRM 9.3.3 -  SSRF (exploitdb)
- EspoCRM <= 9.3.3 - Server-Side Request Forgery (nuclei): http/cves/2026/CVE-2026-33534.yaml

## Other vulnerabilities in espocrm

- [CVE-2014-7985](https://insights.sbomify.com/CVE-2014-7985/): Path traversal in n/a (critical 10.0)
- [CVE-2026-33656](https://insights.sbomify.com/CVE-2026-33656/): Path traversal in espocrm (critical 9.1)
- [CVE-2022-38843](https://insights.sbomify.com/CVE-2022-38843/): File upload in n/a (high 8.8)
- [CVE-2019-14351](https://insights.sbomify.com/CVE-2019-14351/): Information disclosure in n/a (high 8.8)
- [CVE-2020-37094](https://insights.sbomify.com/CVE-2020-37094/): EspoCRM 5.7.0 < 5.9.0 - Two-Factor Authentication Bypass via Auth Token Reuse Between Accounts with Identical Passwords (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33534 and fix it if it is affected.

What it is: CVE-2026-33534 is a medium-severity server-side request forgery vulnerability in espocrm, published on 13 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33534 exists.

Affected product: espocrm. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33534/ (Markdown: https://insights.sbomify.com/CVE-2026-33534/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33534
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33534
- OSV: https://osv.dev/vulnerability/CVE-2026-33534

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33534/
Summaries are generated and may contain mistakes; the official description above is the record.
