CVE-2026-33538 Parse Server: Denial of service via unindexed database query for unconfigured auth providers
Unauthenticated attackers can cause denial of service by triggering full database scans via requests to unconfigured authentication providers.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-33538?
CVE-2026-33538 is a high-severity denial of service vulnerability in Parseplatform Parse-Server, published on 24 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.58 and 9.6.0-alpha.52, an unauthenticated attacker can cause denial of service by sending authentication requests with arbitrary, unconfigured provider names. The server executes a database query for each unconfigured provider before rejecting the request, and since no database index exists for unconfigured providers, each request triggers a full collection scan on the user database. This can be parallelized to saturate database resources. This issue has been patched in versions 8.6.58 and 9.6.0-alpha.52.
Weakness: CWE-400
Which versions are affected by CVE-2026-33538?
5 open source packages ship an affected version, including parse-server and parse. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
parse-server npm | All versions | 8.6.58 |
parse-server npm | All versions | 8.6.58 |
parse-server npm | From 9.0.0 | 9.6.0-alpha.52 |
parse-server npm | From 9.0.0 | 9.6.0-alpha.52 |
parse Bitnami | All versions | 8.6.58, 9.6.0 |
Products include Parseplatform Parse-Server.
How do I fix CVE-2026-33538?
Upgrade parse-server to a fixed version for your release line: 8.6.58 or 9.6.0-alpha.52.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-33538 being exploited?
There is no known exploitation of CVE-2026-33538 in the wild and no public exploit code.
Other vulnerabilities in Parseplatform Parse-Server
- CVE-2026-30966 Parse Server role escalation and CLP bypass via direct `_Join` table write
- CVE-2024-27298 Parse Server literalizeRegexPart SQL Injection
- CVE-2022-24760 Command Injection in Parse server
- CVE-2026-30965 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter
- CVE-2023-36475 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution
Sources
Also known as BIT-parse-2026-33538, GHSA-g4cf-xj29-wqqr.