# CVE-2026-33542: Incus does not verify combined fingerprint when downloading images from simplestreams servers

> Attackers can poison image caches by bypassing fingerprint validation, potentially forcing tenants to run malicious images.

- **Severity:** Medium 5.7 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:L/VI:H/VA:N/SC:L/SI:H/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Mar 2026
- **Updated:** 30 Mar 2026
- **Also known as:** DEBIAN-CVE-2026-33542, GHSA-p8mm-23gg-jc9r, GO-2026-4882, UBUNTU-CVE-2026-33542

## What is CVE-2026-33542?

CVE-2026-33542 is a medium-severity vulnerability in lxc incus, published on 26 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Incus is a system container and virtual machine manager. Prior to version 6.23.0, a lack of validation of the image fingerprint when downloading from simplestreams image servers opens the door to image cache poisoning and under very narrow circumstances exposes other tenants to running attacker controlled images rather than the expected one. Version 6.23.0 patches the issue.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2026-33542?

4 open source packages ship an affected version, including github.com/lxc/incus/v6/client, github.com/lxc/incus and github.com/lxc/incus/v6. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/lxc/incus/v6/client` | Go | All versions | 6.23.0 |
| `github.com/lxc/incus/v6/client` | Go | All versions | 6.23.0 |
| `github.com/lxc/incus` | Go | All versions | None |
| `github.com/lxc/incus/v6` | Go | All versions | 6.23.0 |

Products: Linuxcontainers Incus.

## How do I fix CVE-2026-33542?

Upgrade github.com/lxc/incus/v6/client to 6.23.0 or later.

## Is CVE-2026-33542 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33542 exists.

## Other vulnerabilities in lxc incus

- [CVE-2026-33897](https://insights.sbomify.com/CVE-2026-33897/): Incus vulnerable to arbitrary file read and write through pongo templates (critical 10.0)
- [CVE-2026-33945](https://insights.sbomify.com/CVE-2026-33945/): Abitrary file write through systemd-creds option (critical 10.0)
- [CVE-2026-33898](https://insights.sbomify.com/CVE-2026-33898/): Local Incus UI web server vulnerable to nuthentication bypass (high 8.8)
- [CVE-2026-23953](https://insights.sbomify.com/CVE-2026-23953/): Incus container environment configuration newline injection (high 8.7)
- [CVE-2026-23954](https://insights.sbomify.com/CVE-2026-23954/): Incus container image templating arbitrary host file read and write (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33542 and fix it if it is affected.

What it is: CVE-2026-33542 is a medium-severity vulnerability in lxc incus, published on 26 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33542 exists.

Affected packages and fixed versions:
- github.com/lxc/incus/v6/client (Go): affected all versions; fixed in 6.23.0
- github.com/lxc/incus/v6/client (Go): affected all versions; fixed in 6.23.0
- github.com/lxc/incus (Go): affected all versions; no fix listed
- github.com/lxc/incus/v6 (Go): affected all versions; fixed in 6.23.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33542/ (Markdown: https://insights.sbomify.com/CVE-2026-33542/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33542
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33542
- OSV: https://osv.dev/vulnerability/CVE-2026-33542

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33542/
Summaries are generated and may contain mistakes; the official description above is the record.
