# CVE-2026-33555: Other in HAProxy

> An attacker can exploit HTTP/3 parser flaws in HAProxy to cause request smuggling and desynchronize backend servers, potentially bypassing security controls.

- **Severity:** Medium 4.0 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Apr 2026
- **Updated:** 18 Oct 2026
- **Also known as:** AZL-82730, BIT-haproxy-2026-33555, DEBIAN-CVE-2026-33555, GHSA-5mp8-rq5m-pj7m, MGASA-2026-0146, MINI-frr2-6qcm-2x7q, MINI-jm4x-3pq6-hxvm, OESA-2026-2083, OESA-2026-2084, OESA-2026-2085, OESA-2026-2086, RHSA-2026:8749, SUSE-SU-2026:1568-1, SUSE-SU-2026:21280-1, SUSE-SU-2026:21289-1, SUSE-SU-2026:21318-1, SUSE-SU-2026:21353-1, SUSE-SU-2026:21390-1, UBUNTU-CVE-2026-33555, openSUSE-SU-2026:10581-1, openSUSE-SU-2026:20618-1

## What is CVE-2026-33555?

CVE-2026-33555 is a medium-severity vulnerability in HAProxy, published on 13 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in HAProxy before 3.3.6. The HTTP/3 parser does not check that the received body length matches a previously announced content-length when the stream is closed via a frame with an empty payload. This can cause desynchronization issues with the backend server and could be used for request smuggling. The earliest affected version is 2.6.

Weakness: CWE-130 (Improper Handling of Length Parameter Inconsistency)

## Which versions are affected by CVE-2026-33555?

1 open source package ship an affected version, including haproxy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `haproxy` | Bitnami | From 2.6.0 | 3.3.6 |
| `haproxy` | Red Hat:hummingbird:1 | All versions | 0:3.0.19-1.1.hum1 |
| `haproxy` | SUSE:Linux Enterprise High Availability Extension 15 SP6 | All versions | 2.8.11+git0.01c1056a4-150600.3.12.1 |
| `haproxy` | SUSE:Linux Enterprise High Availability Extension 15 SP7 | All versions | 2.8.11+git0.01c1056a4-150600.3.12.1 |
| `haproxy` | SUSE:Linux Micro 6.2 | All versions | 3.2.15+git64.0fc44b458-160000.2.1 |
| `haproxy` | openSUSE:Leap 16.0 | All versions | 3.2.15+git64.0fc44b458-160000.2.1 |
| `haproxy` | openSUSE:Tumbleweed | All versions | 3.3.6+git91.af5637e93-1.1 |

Products: Haproxy Haproxy.

## How do I fix CVE-2026-33555?

Upgrade haproxy to 3.3.6 or later.

## Is CVE-2026-33555 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33555 exists.

Public exploit code:

- One zero-byte QUIC packet is enough to desynchronize HAProxy's backend connection pool and smuggle HTTP requests across unrelated users — even users on a completely different frontend protocol. (github_poc): https://github.com/r3verii/CVE-2026-33555

## Other vulnerabilities in HAProxy

- [CVE-2026-55203](https://insights.sbomify.com/CVE-2026-55203/): HAProxy - Integer Overflow in FCGI Demux Record Length Field (critical 9.0)
- [CVE-2026-55204](https://insights.sbomify.com/CVE-2026-55204/): HAProxy - NULL Pointer Dereference in hpack_dht_insert Function (high 8.7)
- [CVE-2023-45539](https://insights.sbomify.com/CVE-2023-45539/): Information disclosure in n/a (high 8.2)
- [CVE-2024-45506](https://insights.sbomify.com/CVE-2024-45506/): Denial of service in n/a (high 7.5)
- [CVE-2023-0836](https://insights.sbomify.com/CVE-2023-0836/): Information disclosure in HAProxy (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33555 and fix it if it is affected.

What it is: CVE-2026-33555 is a medium-severity vulnerability in HAProxy, published on 13 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33555 exists.

Affected packages and fixed versions:
- haproxy (Bitnami): affected from 2.6.0; fixed in 3.3.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33555/ (Markdown: https://insights.sbomify.com/CVE-2026-33555/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33555
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33555
- OSV: https://osv.dev/vulnerability/CVE-2026-33555

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33555/
Summaries are generated and may contain mistakes; the official description above is the record.
