{"answers":{"affected":"3 open source packages ship an affected version, including org.apache.kafka:kafka-clients and kafka. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-33557 in the wild and no public exploit code.","fix":"Upgrade org.apache.kafka:kafka-clients to 4.1.2 or later.","what":"CVE-2026-33557 is a critical authentication bypass vulnerability in Apache Kafka, published on 20 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-33557 and fix it if it is affected.\n\nWhat it is: CVE-2026-33557 is a critical authentication bypass vulnerability in Apache Kafka, published on 20 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-33557 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.kafka:kafka-clients (Maven): affected from 4.1.0; fixed in 4.1.2\n- org.apache.kafka:kafka-clients (Maven): affected from 4.1.0; fixed in 4.1.2\n- kafka (Bitnami): affected from 4.1.0; fixed in 4.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-33557/ (Markdown: https://insights.sbomify.com/CVE-2026-33557/index.md)","id":"CVE-2026-33557","markdown":"https://insights.sbomify.com/CVE-2026-33557/index.md","name":"CVE-2026-33557","record":{"aliases":["BIT-kafka-2026-33557","CLEANSTART-2026-AD78101","ECHO-0295-5664-07c7","GHSA-28jg-cgg7-j4wc","MINI-52p4-fv3h-m2c7","MINI-59xj-jqx3-j4cp","MINI-6mxh-fvmf-w89c","MINI-8cr5-9q7j-h7xv","MINI-8r3r-vhgx-4x65","MINI-8wc9-hg9h-45pw","MINI-fqr4-5vx2-q992","MINI-v3x3-v42x-qxf9","MINI-wghq-m7fc-x2wq","UBUNTU-CVE-2026-33557"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["privilege_escalation","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Kafka","requires_auth":"none","summary":"Apache Kafka accepts unsigned JWT tokens by default, allowing attackers to impersonate any user and bypass authentication controls.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"kafka","vendor":"apache"}],"cvss":{"score":9.1,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-303","name":"Incorrect Implementation of Authentication Algorithm"},{"id":"CWE-1285","name":"Improper Validation of Specified Index, Position, or Offset in Input"}],"description":"A possible security vulnerability has been identified in Apache Kafka.\n\nBy default, the broker property `sasl.oauthbearer.jwt.validator.class` is set to `org.apache.kafka.common.security.oauthbearer.DefaultJwtValidator`. It accepts any JWT token without validating its signature, issuer, or audience. An attacker can generate a JWT token from any issuer with the `preferred_username` set to any user, and the broker will accept it.\n\nWe advise the Kafka users using kafka v4.1.0 or v4.1.1 to set the config `sasl.oauthbearer.jwt.validator.class` to `org.apache.kafka.common.security.oauthbearer.BrokerJwtValidator` explicitly to avoid this vulnerability. Since Kafka v4.1.2 and v4.2.0 and later, the issue is fixed and will correctly validate the JWT token.","ecosystems":["Bitnami","Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Kafka: Missing JWT token validation in OAUTHBEARER authentication","id":"CVE-2026-33557","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"auth_bypass","year":"2026"},"n_packages":3,"n_references":2,"next":{"headline":"Apache Kafka, Apache Kafka Clients: Information Exposure Through Network Client Log Output","id":"CVE-2026-33558"},"packages":[{"ecosystem":"Bitnami","fixed":["4.1.2"],"introduced":["4.1.0"],"last_affected":[],"package":"kafka","purl":"pkg:bitnami/kafka","source":"BIT-kafka-2026-33557"},{"ecosystem":"Maven","fixed":["4.1.2"],"introduced":["4.1.0"],"last_affected":[],"package":"org.apache.kafka:kafka-clients","purl":null,"source":"GHSA-28jg-cgg7-j4wc"},{"ecosystem":"Maven","fixed":["4.1.2"],"introduced":["4.1.0"],"last_affected":[],"package":"org.apache.kafka:kafka-clients","purl":"pkg:maven/org.apache.kafka/kafka-clients","source":"GHSA-28jg-cgg7-j4wc"}],"prev":{"headline":"Other in HAProxy","id":"CVE-2026-33555"},"products":["Apache Kafka"],"published":"2026-04-20","related":[{"cvss_score":8.8,"headline":"Apache Kafka: Possible RCE attack via SASL JAAS LdapLoginModule configuration","id":"CVE-2025-27818","kev_date_added":null,"published":"2025-06-10"},{"cvss_score":8.8,"headline":"Improper Input Validation in Apache Kafka","id":"CVE-2018-17196","kev_date_added":null,"published":"2019-07-11"},{"cvss_score":8.7,"headline":"Apache Kafka Clients: Kafka Producer Message Corruption and Misrouting via Buffer Pool Race Condition","id":"CVE-2026-35554","kev_date_added":null,"published":"2026-04-07"},{"cvss_score":7.5,"headline":"Apache Kafka Client: Arbitrary file read and SSRF vulnerability","id":"CVE-2025-27817","kev_date_added":null,"published":"2025-06-10"},{"cvss_score":7.5,"headline":"Apache Kafka: Possible RCE/Denial of service attack via SASL JAAS JndiLoginModule configuration","id":"CVE-2025-27819","kev_date_added":null,"published":"2025-06-10"},{"cvss_score":7.5,"headline":"Unauthenticated clients may cause OutOfMemoryError on Apache Kafka Brokers","id":"CVE-2022-34917","kev_date_added":null,"published":"2022-09-20"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-15","vendors":["Apache Software Foundation"]},"summary":"Apache Kafka accepts unsigned JWT tokens by default, allowing attackers to impersonate any user and bypass authentication controls.","url":"https://insights.sbomify.com/CVE-2026-33557/"}