CVE-2026-33558 Apache Kafka, Apache Kafka Clients: Information Exposure Through Network Client Log Output
Attackers with log access can view sensitive credentials and tokens if DEBUG logging is enabled in Apache Kafka NetworkClient.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-33558?
CVE-2026-33558 is a medium-severity vulnerability in Apache Kafka, published on 20 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Information exposure vulnerability has been identified in Apache Kafka.
The NetworkClient component will output entire requests and responses information in the DEBUG log level in the logs. By default, the log level is set to INFO level. If the DEBUG level is enabled, the sensitive information will be exposed via the requests and responses output log. The entire lists of impacted requests and responses are:
* AlterConfigsRequest
* AlterUserScramCredentialsRequest
* ExpireDelegationTokenRequest
* IncrementalAlterConfigsRequest
* RenewDelegationTokenRequest
* SaslAuthenticateRequest
* createDelegationTokenResponse
* describeDelegationTokenResponse
* SaslAuthenticateResponse
This issue affects Apache Kafka: from any version supported the listed API above through v3.9.1, v4.0.0. We advise the Kafka users to upgrade to v3.9.2, v4.0.1, or later to avoid this vulnerability.
Weakness: CWE-533
Which versions are affected by CVE-2026-33558?
5 open source packages ship an affected version, including org.apache.kafka:kafka-clients and kafka. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.kafka:kafka-clients Maven | From 0.11.0 | 3.9.2 |
org.apache.kafka:kafka-clients Maven | From 0.11.0 | 3.9.2 |
org.apache.kafka:kafka-clients Maven | From 4.0.0 | 4.0.1 |
org.apache.kafka:kafka-clients Maven | From 4.0.0 | 4.0.1 |
kafka Bitnami | From 0.11.0 | 3.9.2, 4.0.1 |
Products include Apache Kafka.
How do I fix CVE-2026-33558?
Upgrade org.apache.kafka:kafka-clients to a fixed version for your release line: 3.9.2 or 4.0.1.
Is CVE-2026-33558 being exploited?
There is no known exploitation of CVE-2026-33558 in the wild and no public exploit code.
Other vulnerabilities in Apache Kafka
- CVE-2026-33557 Apache Kafka: Missing JWT token validation in OAUTHBEARER authentication
- CVE-2025-27818 Apache Kafka: Possible RCE attack via SASL JAAS LdapLoginModule configuration
- CVE-2018-17196 Improper Input Validation in Apache Kafka
- CVE-2026-35554 Apache Kafka Clients: Kafka Producer Message Corruption and Misrouting via Buffer Pool Race Condition
- CVE-2025-27817 Apache Kafka Client: Arbitrary file read and SSRF vulnerability
Sources
Also known as BIT-kafka-2026-33558, CLEANSTART-2026-GB58847, CLEANSTART-2026-GO69632, CLEANSTART-2026-KN06820, CLEANSTART-2026-MN19419, CLEANSTART-2026-YH51539 and 27 more.