# CVE-2026-33558: Apache Kafka, Apache Kafka Clients: Information Exposure Through Network Client Log Output

> Attackers with log access can view sensitive credentials and tokens if DEBUG logging is enabled in Apache Kafka NetworkClient.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Apr 2026
- **Updated:** 20 Apr 2026
- **Also known as:** BIT-kafka-2026-33558, CLEANSTART-2026-GB58847, CLEANSTART-2026-GO69632, CLEANSTART-2026-KN06820, CLEANSTART-2026-MN19419, CLEANSTART-2026-YH51539, ECHO-5b43-5c55-4671, GHSA-wf66-mphr-4c4r, MINI-2f8w-p58c-fp9q, MINI-39cf-9jvx-phqh, MINI-3hhw-vhmh-x577, MINI-48r9-7xpg-cgp4, MINI-4rj7-9m56-xjh4, MINI-4w65-qhxg-8px3, MINI-6w44-5m9f-vxqj, MINI-72f6-7r9f-4cp4, MINI-83p2-3fjh-hvfv, MINI-cmh2-2p4p-4c62, MINI-gcx9-x85r-3pf6, MINI-gw8x-8w5p-2r4v, MINI-hqgv-7r2r-q857, MINI-j44f-7q83-xf3r, MINI-m2mv-qgfg-x7pj, MINI-ph8v-8478-4mmc, MINI-px4v-mhhq-wqm5, MINI-qcxv-cxpr-6qmw, MINI-rfhr-qc26-chj6, MINI-rq5c-fgp3-8vxc, MINI-v4j9-rxq3-hcvx, MINI-x4vx-65xj-6rvq, MINI-xf3j-c755-vjr3, ROOT-APP-MAVEN-CVE-2026-33558, UBUNTU-CVE-2026-33558

## What is CVE-2026-33558?

CVE-2026-33558 is a medium-severity vulnerability in Apache Kafka, published on 20 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Information exposure vulnerability has been identified in Apache Kafka.

The NetworkClient component will output entire requests and responses information in the DEBUG log level in the logs. By default, the log level is set to INFO level. If the DEBUG level is enabled, the sensitive information will be exposed via the requests and responses output log. The entire lists of impacted requests and responses are:

  *  AlterConfigsRequest

  *  AlterUserScramCredentialsRequest

  *  ExpireDelegationTokenRequest

  *  IncrementalAlterConfigsRequest

  *  RenewDelegationTokenRequest

  *  SaslAuthenticateRequest

  *  createDelegationTokenResponse

  *  describeDelegationTokenResponse

  *  SaslAuthenticateResponse

This issue affects Apache Kafka: from any version supported the listed API above through v3.9.1, v4.0.0. We advise the Kafka users to upgrade to v3.9.2, v4.0.1, or later to avoid this vulnerability.

Weakness: CWE-533 (DEPRECATED: Information Exposure Through Server Log Files)

## Which versions are affected by CVE-2026-33558?

5 open source packages ship an affected version, including org.apache.kafka:kafka-clients and kafka. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.kafka:kafka-clients` | Maven | From 0.11.0 | 3.9.2 |
| `org.apache.kafka:kafka-clients` | Maven | From 0.11.0 | 3.9.2 |
| `org.apache.kafka:kafka-clients` | Maven | From 4.0.0 | 4.0.1 |
| `org.apache.kafka:kafka-clients` | Maven | From 4.0.0 | 4.0.1 |
| `kafka` | Bitnami | From 0.11.0 | 3.9.2, 4.0.1 |

Products: Apache Kafka.

## How do I fix CVE-2026-33558?

Upgrade org.apache.kafka:kafka-clients to a fixed version for your release line: 3.9.2 or 4.0.1.

## Is CVE-2026-33558 being exploited?

There is no known exploitation of CVE-2026-33558 in the wild and no public exploit code.

## Other vulnerabilities in Apache Kafka

- [CVE-2026-33557](https://insights.sbomify.com/CVE-2026-33557/): Apache Kafka: Missing JWT token validation in OAUTHBEARER authentication (critical 9.1)
- [CVE-2025-27818](https://insights.sbomify.com/CVE-2025-27818/): Apache Kafka: Possible RCE attack via SASL JAAS LdapLoginModule configuration (high 8.8)
- [CVE-2018-17196](https://insights.sbomify.com/CVE-2018-17196/): Improper Input Validation in Apache Kafka (high 8.8)
- [CVE-2026-35554](https://insights.sbomify.com/CVE-2026-35554/): Apache Kafka Clients: Kafka Producer Message Corruption and Misrouting via Buffer Pool Race Condition (high 8.7)
- [CVE-2025-27817](https://insights.sbomify.com/CVE-2025-27817/): Apache Kafka Client: Arbitrary file read and SSRF vulnerability (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33558 and fix it if it is affected.

What it is: CVE-2026-33558 is a medium-severity vulnerability in Apache Kafka, published on 20 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33558 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.kafka:kafka-clients (Maven): affected from 0.11.0; fixed in 3.9.2
- org.apache.kafka:kafka-clients (Maven): affected from 0.11.0; fixed in 3.9.2
- org.apache.kafka:kafka-clients (Maven): affected from 4.0.0; fixed in 4.0.1
- org.apache.kafka:kafka-clients (Maven): affected from 4.0.0; fixed in 4.0.1
- kafka (Bitnami): affected from 0.11.0; fixed in 3.9.2, 4.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33558/ (Markdown: https://insights.sbomify.com/CVE-2026-33558/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33558
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33558
- OSV: https://osv.dev/vulnerability/CVE-2026-33558

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33558/
Summaries are generated and may contain mistakes; the official description above is the record.
