CVE-2026-33572 OpenClaw < 2026.2.17 - Insufficient File Permissions in Session Transcript Files
Local attackers can read session transcript files to extract sensitive secrets due to overly broad default file permissions in OpenClaw.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Local or same network only
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-33572?
CVE-2026-33572 is a medium-severity vulnerability in Openclaw Openclaw, published on 29 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Official description
OpenClaw before 2026.2.17 creates session transcript JSONL files with overly broad default permissions, allowing local users to read transcript contents. Attackers with local access can read transcript files to extract sensitive information including secrets from tool output.
Weakness: CWE-378
Which versions are affected by CVE-2026-33572?
2 open source packages ship an affected version, including openclaw. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
openclaw npm | All versions | 2026.2.17 |
openclaw npm | All versions | 2026.2.17 |
Products include Openclaw Openclaw.
How do I fix CVE-2026-33572?
Upgrade openclaw to 2026.2.17 or later.
Is CVE-2026-33572 being exploited?
There is no known exploitation of CVE-2026-33572 in the wild and no public exploit code.
Other vulnerabilities in Openclaw Openclaw
- CVE-2026-28363 Security feature bypass in OpenClaw
- CVE-2026-30741 Code injection in n/a
- CVE-2026-33579 OpenClaw < 2026.3.28 - Privilege Escalation via Missing Caller Scope Validation in Device Pair Approval
- CVE-2026-32922 OpenClaw < 2026.3.11 - Privilege Escalation via Unvalidated Scope in device.token.rotate
- CVE-2026-32978 OpenClaw < 2026.3.11 - Approval Bypass via Unrecognized Script Runners
Sources
Also known as GHSA-vr7j-g7jv-h5mp, MINI-4522-vm3f-gx2c, MINI-jc4c-3837-fhgh.