CVE-2026-33618 Chamilo LMS Affected by Remote Code Execution via eval() in Platform Settings

High 8.8 Published Updated

An attacker with admin access can inject PHP code into platform settings, leading to remote code execution when the settings are viewed.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-33618?

CVE-2026-33618 is a high-severity code injection vulnerability in Chamilo Chamilo Lms, published on 10 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Chamilo LMS is a learning management system. Prior to .0.0-RC.3, the PlatformConfigurationController::decodeSettingArray() method uses PHP's eval() to parse platform settings from the database. An attacker with admin access (obtainable via Advisory 1) can inject arbitrary PHP code into the settings, which is then executed when any user (including unauthenticated) requests /platform-config/list. This vulnerability is fixed in 2.0.0-RC.3.

Weakness: CWE-95

Which versions are affected by CVE-2026-33618?

It affects 1 product.

Products include Chamilo Chamilo Lms.

How do I fix CVE-2026-33618?

No fix has been published for CVE-2026-33618 yet. Limit exposure of the affected software until one is available.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-33618 being exploited?

There is no known exploitation of CVE-2026-33618 in the wild and no public exploit code.

All Chamilo Chamilo Lms vulnerabilities

Sources

Also known as GHSA-hp4w-jmwc-pg7w.

Is CVE-2026-33618 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free