# CVE-2026-33623: PinchTab: OS Command Injection via Profile Name in Windows Cleanup Routine Enables Arbitrary Command Execution

> Authenticated attackers can execute arbitrary PowerShell commands on Windows hosts via crafted profile names in PinchTab's cleanup routine.

- **Severity:** Medium 6.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Mar 2026
- **Updated:** 27 Mar 2026
- **Also known as:** GHSA-p8mm-644p-phmh, GO-2026-4823

## What is CVE-2026-33623?

CVE-2026-33623 is a medium-severity command injection vulnerability in pinchtab, published on 26 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

PinchTab is a standalone HTTP server that gives AI agents direct control over a Chrome browser. PinchTab `v0.8.4` contains a Windows-only command injection issue in the orphaned Chrome cleanup path. When an instance is stopped, the Windows cleanup routine builds a PowerShell `-Command` string using a `needle` derived from the profile path. In `v0.8.4`, that string interpolation escapes backslashes but does not safely neutralize other PowerShell metacharacters. If an attacker can launch an instance using a crafted profile name and then trigger the cleanup path, they may be able to execute arbitrary PowerShell commands on the Windows host in the security context of the PinchTab process user. This is not an unauthenticated internet RCE. It requires authenticated, administrative-equivalent API access to instance lifecycle endpoints, and the resulting command execution inherits the permissions of the PinchTab OS user rather than bypassing host privilege boundaries. Version 0.8.5 contains a patch for the issue.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-33623?

5 open source packages ship an affected version, including github.com/pinchtab/pinchtab and github.com/pinchtab/pinchtab/cmd/pinchtab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/pinchtab/pinchtab` | Go | All versions | 0.8.5 |
| `github.com/pinchtab/pinchtab` | Go | All versions | 0.8.5 |
| `github.com/pinchtab/pinchtab` | Go | All versions | 0.8.5 |
| `github.com/pinchtab/pinchtab/cmd/pinchtab` | Go | All versions | 0.8.5 |
| `github.com/pinchtab/pinchtab/cmd/pinchtab` | Go | All versions | 0.8.5 |

Products: Pinchtab Pinchtab.

## How do I fix CVE-2026-33623?

Upgrade github.com/pinchtab/pinchtab to 0.8.5 or later.

## Is CVE-2026-33623 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33623 exists.

## Other vulnerabilities in pinchtab

- [CVE-2026-30834](https://insights.sbomify.com/CVE-2026-30834/): PinchTab: SSRF with Full Response Exfiltration via Download Handler (high 7.5)
- [CVE-2026-33622](https://insights.sbomify.com/CVE-2026-33622/): A PinchTab Security Policy Bypass in /wait Allows Arbitrary JavaScript Execution (medium 6.1)
- [CVE-2026-33081](https://insights.sbomify.com/CVE-2026-33081/): PinchTab has Blind SSRF via browser-side redirect bypass in /download URL validation (medium 5.8)
- [CVE-2026-33621](https://insights.sbomify.com/CVE-2026-33621/): PinchTab: Unapplied Rate Limiting Middleware Allows Unbounded Brute-Force of API Token (medium 4.8)
- [CVE-2026-33620](https://insights.sbomify.com/CVE-2026-33620/): PinchTab: API Bearer Token Exposed in URL Query Parameter via Server Logs and Intermediary Systems (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33623 and fix it if it is affected.

What it is: CVE-2026-33623 is a medium-severity command injection vulnerability in pinchtab, published on 26 Mar 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33623 exists.

Affected packages and fixed versions:
- github.com/pinchtab/pinchtab (Go): affected all versions; fixed in 0.8.5
- github.com/pinchtab/pinchtab (Go): affected all versions; fixed in 0.8.5
- github.com/pinchtab/pinchtab (Go): affected all versions; fixed in 0.8.5
- github.com/pinchtab/pinchtab/cmd/pinchtab (Go): affected all versions; fixed in 0.8.5
- github.com/pinchtab/pinchtab/cmd/pinchtab (Go): affected all versions; fixed in 0.8.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33623/ (Markdown: https://insights.sbomify.com/CVE-2026-33623/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33623
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33623
- OSV: https://osv.dev/vulnerability/CVE-2026-33623

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33623/
Summaries are generated and may contain mistakes; the official description above is the record.
