{"answers":{"affected":"3 open source packages ship an affected version, including lmdeploy.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33625 exists.","fix":"Upgrade lmdeploy to 0.12.3 or later.","what":"CVE-2026-33625 is a high-severity code injection vulnerability in InternLM lmdeploy, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-33625 and fix it if it is affected.\n\nWhat it is: CVE-2026-33625 is a high-severity code injection vulnerability in InternLM lmdeploy, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33625 exists.\n\nAffected packages and fixed versions:\n- lmdeploy (PyPI): affected from 0.12.1; fixed in 0.12.3\n- lmdeploy (PyPI): affected from 0.12.1; fixed in 0.12.3\n- lmdeploy (PyPI): affected from 0.12.1; fixed in 0.12.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-33625/ (Markdown: https://insights.sbomify.com/CVE-2026-33625/index.md)","id":"CVE-2026-33625","markdown":"https://insights.sbomify.com/CVE-2026-33625/index.md","name":"CVE-2026-33625","record":{"aliases":["GHSA-3hmm-rh5q-gwwr","PYSEC-2026-4078"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"LLM deployment toolkit","requires_auth":"none","summary":"Attackers can execute arbitrary code by publishing malicious HuggingFace models with crafted quantization configs, affecting LMDeploy users.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"LMDeploy is a toolkit for compressing, deploying, and serving large language models. Versions 012.1 through 0.12.2 contain a code injection vulnerability in `lmdeploy/pytorch/config.py` line 620 that allows an attacker to execute arbitrary Python code by publishing a malicious HuggingFace model with a crafted `quantization_config.quant_dtype` value. When a user loads the model with lmdeploy, the `quant_dtype` is passed to `eval(f'torch.{quant_dtype}')` without any validation. Version 0.12.3 contains a patch.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"LMDeploy vulnerable to arbitrary code execution via eval() of untrusted quant_dtype in model config loading","id":"CVE-2026-33625","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":3,"n_references":2,"next":{"headline":"LMDeploy Vulnerable to Server-Side Request Forgery (SSRF) via Vision-Language Image Loading","id":"CVE-2026-33626"},"packages":[{"ecosystem":"PyPI","fixed":["0.12.3"],"introduced":["0.12.1"],"last_affected":[],"package":"lmdeploy","purl":null,"source":"GHSA-3hmm-rh5q-gwwr"},{"ecosystem":"PyPI","fixed":["0.12.3"],"introduced":["0.12.1"],"last_affected":[],"package":"lmdeploy","purl":"pkg:pypi/lmdeploy","source":"GHSA-3hmm-rh5q-gwwr"},{"ecosystem":"PyPI","fixed":["0.12.3"],"introduced":["0.12.1"],"last_affected":[],"package":"lmdeploy","purl":"pkg:pypi/lmdeploy","source":"PYSEC-2026-4078"}],"prev":{"headline":"Parse Server: MFA recovery code single-use bypass via concurrent requests","id":"CVE-2026-33624"},"products":["lmdeploy"],"published":"2026-09-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-22","vendors":["InternLM"]},"summary":"Attackers can execute arbitrary code by publishing malicious HuggingFace models with crafted quantization configs, affecting LMDeploy users.","url":"https://insights.sbomify.com/CVE-2026-33625/"}