# CVE-2026-33625: LMDeploy vulnerable to arbitrary code execution via eval() of untrusted quant_dtype in model config loading

> Attackers can execute arbitrary code by publishing malicious HuggingFace models with crafted quantization configs, affecting LMDeploy users.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Sep 2026
- **Updated:** 22 Sep 2026
- **Also known as:** GHSA-3hmm-rh5q-gwwr, PYSEC-2026-4078

## What is CVE-2026-33625?

CVE-2026-33625 is a high-severity code injection vulnerability in InternLM lmdeploy, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

LMDeploy is a toolkit for compressing, deploying, and serving large language models. Versions 012.1 through 0.12.2 contain a code injection vulnerability in `lmdeploy/pytorch/config.py` line 620 that allows an attacker to execute arbitrary Python code by publishing a malicious HuggingFace model with a crafted `quantization_config.quant_dtype` value. When a user loads the model with lmdeploy, the `quant_dtype` is passed to `eval(f'torch.{quant_dtype}')` without any validation. Version 0.12.3 contains a patch.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-33625?

3 open source packages ship an affected version, including lmdeploy.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `lmdeploy` | PyPI | From 0.12.1 | 0.12.3 |
| `lmdeploy` | PyPI | From 0.12.1 | 0.12.3 |
| `lmdeploy` | PyPI | From 0.12.1 | 0.12.3 |

## How do I fix CVE-2026-33625?

Upgrade lmdeploy to 0.12.3 or later.

## Is CVE-2026-33625 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33625 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33625 and fix it if it is affected.

What it is: CVE-2026-33625 is a high-severity code injection vulnerability in InternLM lmdeploy, published on 18 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33625 exists.

Affected packages and fixed versions:
- lmdeploy (PyPI): affected from 0.12.1; fixed in 0.12.3
- lmdeploy (PyPI): affected from 0.12.1; fixed in 0.12.3
- lmdeploy (PyPI): affected from 0.12.1; fixed in 0.12.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33625/ (Markdown: https://insights.sbomify.com/CVE-2026-33625/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33625
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33625
- OSV: https://osv.dev/vulnerability/CVE-2026-33625

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33625/
Summaries are generated and may contain mistakes; the official description above is the record.
