{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33633 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2026-33633 is a high-severity memory corruption vulnerability in kovidgoyal kitty, published on 19 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-33633 and fix it if it is affected.\n\nWhat it is: CVE-2026-33633 is a high-severity memory corruption vulnerability in kovidgoyal kitty, published on 19 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33633 exists.\n\nAffected product: kovidgoyal kitty. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-33633/ (Markdown: https://insights.sbomify.com/CVE-2026-33633/index.md)","id":"CVE-2026-33633","markdown":"https://insights.sbomify.com/CVE-2026-33633/index.md","name":"CVE-2026-33633","record":{"aliases":["DEBIAN-CVE-2026-33633","GHSA-j68c-v8x4-269g","UBUNTU-CVE-2026-33633"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["denial_of_service","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"GPU terminal emulator","requires_auth":"none","summary":"A heap buffer overflow in the Kitty terminal allows attackers to cause denial of service or potentially execute arbitrary code via crafted graphics protocol commands.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"kitty","vendor":"kovidgoyal"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-122","name":"Heap-based Buffer Overflow"}],"description":"Kitty is a cross-platform GPU based terminal. Versions 0.46.2 and below contain a heap buffer overflow in load_image_data() that allows any process which can write to the terminal's stdin to crash kitty immediately. The vulnerability is triggered by a single APC graphics protocol command with a PNG format declaration (f=100) whose payload exceeds twice the initial buffer capacity. The overflow is attacker-controlled in both length and content, causing DoS and potentially escalation to RCE itself. This issue has been fixed in version 0.47.0.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Kitty has a Heap Buffer Overflow in its Graphics Protocol Handler","id":"CVE-2026-33633","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2026"},"n_packages":0,"n_references":2,"next":{"headline":"Aquasecurity Trivy Embedded Malicious Code","id":"CVE-2026-33634"},"packages":[],"prev":{"headline":"ClearanceKit: opfilter policy bypass via exchangedata and clone operations","id":"CVE-2026-33632"},"products":["kitty"],"published":"2026-05-19","related":[{"cvss_score":9.9,"headline":"Kitty has a Heap Buffer Over-Read/Write via Integer Overflow in compose_rectangles Bounds Check","id":"CVE-2026-33642","kev_date_added":null,"published":"2026-05-19"},{"cvss_score":7.8,"headline":"@kitty-edit DCS + --color=geninclude vulnerable to Unauthenticated in-process RCE","id":"CVE-2026-42851","kev_date_added":null,"published":"2026-06-12"},{"cvss_score":7.6,"headline":"Kitty has an arbitrary file overwrite via symlink following in `kitten dnd` remote drop staging","id":"CVE-2026-54056","kev_date_added":null,"published":"2026-06-12"},{"cvss_score":7.4,"headline":"Kitty has a shell command injection","id":"CVE-2026-42850","kev_date_added":null,"published":"2026-06-12"},{"cvss_score":7.3,"headline":"Kitty vulnerable to command injection via unsanitized OSC 21 query reply","id":"CVE-2026-54057","kev_date_added":null,"published":"2026-06-12"},{"cvss_score":5,"headline":"Kitty has an Arbitrary File Write via Symlink Race Condition in File Transmission Protocol","id":"CVE-2026-54055","kev_date_added":null,"published":"2026-06-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-20","vendors":["kovidgoyal"]},"summary":"A heap buffer overflow in the Kitty terminal allows attackers to cause denial of service or potentially execute arbitrary code via crafted graphics protocol commands.","url":"https://insights.sbomify.com/CVE-2026-33633/"}