# CVE-2026-33633: Kitty has a Heap Buffer Overflow in its Graphics Protocol Handler

> A heap buffer overflow in the Kitty terminal allows attackers to cause denial of service or potentially execute arbitrary code via crafted graphics protocol commands.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 May 2026
- **Updated:** 20 May 2026
- **Also known as:** DEBIAN-CVE-2026-33633, GHSA-j68c-v8x4-269g, UBUNTU-CVE-2026-33633

## What is CVE-2026-33633?

CVE-2026-33633 is a high-severity memory corruption vulnerability in kovidgoyal kitty, published on 19 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Kitty is a cross-platform GPU based terminal. Versions 0.46.2 and below contain a heap buffer overflow in load_image_data() that allows any process which can write to the terminal's stdin to crash kitty immediately. The vulnerability is triggered by a single APC graphics protocol command with a PNG format declaration (f=100) whose payload exceeds twice the initial buffer capacity. The overflow is attacker-controlled in both length and content, causing DoS and potentially escalation to RCE itself. This issue has been fixed in version 0.47.0.

Weakness: CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2026-33633?

It affects 1 product.


Products: Kovidgoyal Kitty.

## How do I fix CVE-2026-33633?

Upgrade to a fixed version.

## Is CVE-2026-33633 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33633 exists.

## Other vulnerabilities in kovidgoyal kitty

- [CVE-2026-33642](https://insights.sbomify.com/CVE-2026-33642/): Kitty has a Heap Buffer Over-Read/Write via Integer Overflow in compose_rectangles Bounds Check (critical 9.9)
- [CVE-2026-42851](https://insights.sbomify.com/CVE-2026-42851/): @kitty-edit DCS + --color=geninclude vulnerable to Unauthenticated in-process RCE (high 7.8)
- [CVE-2026-54056](https://insights.sbomify.com/CVE-2026-54056/): Kitty has an arbitrary file overwrite via symlink following in `kitten dnd` remote drop staging (high 7.6)
- [CVE-2026-42850](https://insights.sbomify.com/CVE-2026-42850/): Kitty has a shell command injection (high 7.4)
- [CVE-2026-54057](https://insights.sbomify.com/CVE-2026-54057/): Kitty vulnerable to command injection via unsanitized OSC 21 query reply (high 7.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33633 and fix it if it is affected.

What it is: CVE-2026-33633 is a high-severity memory corruption vulnerability in kovidgoyal kitty, published on 19 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33633 exists.

Affected product: kovidgoyal kitty. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33633/ (Markdown: https://insights.sbomify.com/CVE-2026-33633/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33633
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33633
- OSV: https://osv.dev/vulnerability/CVE-2026-33633

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33633/
Summaries are generated and may contain mistakes; the official description above is the record.
