# CVE-2026-33637: Faraday: Protocol-relative URI objects still bypass host scoping (possible incomplete fix for GHSA-33mh-2634-fwr2)

> Attackers can bypass host scoping in Faraday HTTP client to redirect requests to malicious hosts, leaking sensitive headers and parameters.

- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 May 2026
- **Updated:** 19 May 2026
- **Also known as:** CLEANSTART-2026-LW94044, CLEANSTART-2026-TE06147, DEBIAN-CVE-2026-33637, GHSA-5rv5-xj5j-3484, MINI-5rfv-cmg2-qqxc, MINI-5vwc-99wm-6fpm, MINI-6qcm-cv6h-mg62, MINI-888x-xgfv-87qw, MINI-8r98-pc9q-7778, MINI-chj3-pr2c-pgx9, MINI-f6wv-m28r-r656, MINI-fc5h-2wgf-ffjv, MINI-fh36-8rhr-hpq3, MINI-fqhw-844c-pg78, MINI-fxpr-h987-ph23, MINI-gq9f-pc55-w8rc, MINI-hm4w-xc33-3qf2, MINI-hmj4-3623-wmqq, MINI-hw3v-jx5f-37pf, MINI-jfg2-xp43-8w8j, MINI-mv48-xj37-c3mp, MINI-mxvf-5895-pv33, MINI-q7xq-m73x-wwh8, MINI-q8fv-jhp2-x356, MINI-rc2h-q8cm-439h, MINI-rqww-rp75-4h6h, MINI-vmg2-3g7g-pgrf, MINI-w2h3-6rvf-74q5, MINI-xqhg-25j9-2x29, UBUNTU-CVE-2026-33637

## What is CVE-2026-33637?

CVE-2026-33637 is a server-side request forgery vulnerability in lostisland faraday, published on 19 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Faraday is an HTTP client library abstraction layer that provides a common interface over many adapters. Versions 2.0.0 through 2.14.1 still allow protocol-relative host override when the request target is passed as a URI object (rather than a String) to Faraday::Connection#build_exclusive_url. This bypasses the February 2026 fix for GHSA-33mh-2634-fwr2 and enables off-host request forgery: a request built from a fixed-base Faraday::Connection can be redirected to an attacker-controlled host, forwarding connection-scoped values such as Authorization headers and default query parameters. This issue has been fixed in version 2.14.3.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-33637?

2 open source packages ship an affected version, including faraday. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `faraday` | RubyGems | From 2.0.0 | 2.14.2 |
| `faraday` | RubyGems | From 2.0.0 | 2.14.2 |

Products: Faraday Project Faraday.

## How do I fix CVE-2026-33637?

Upgrade faraday to 2.14.2 or later.

## Is CVE-2026-33637 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33637 exists.

## Other vulnerabilities in lostisland faraday

- [CVE-2026-54297](https://insights.sbomify.com/CVE-2026-54297/): Faraday: Uncontrolled recursion in NestedParamsEncoder allows stack exhaustion DoS via deeply nested query parameters (high 7.5)
- [CVE-2026-25765](https://insights.sbomify.com/CVE-2026-25765/): Faraday affected by SSRF via protocol-relative URL host override in build_exclusive_url (medium 5.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33637 and fix it if it is affected.

What it is: CVE-2026-33637 is a server-side request forgery vulnerability in lostisland faraday, published on 19 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33637 exists.

Affected packages and fixed versions:
- faraday (RubyGems): affected from 2.0.0; fixed in 2.14.2
- faraday (RubyGems): affected from 2.0.0; fixed in 2.14.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33637/ (Markdown: https://insights.sbomify.com/CVE-2026-33637/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33637
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33637
- OSV: https://osv.dev/vulnerability/CVE-2026-33637

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33637/
Summaries are generated and may contain mistakes; the official description above is the record.
