# CVE-2026-33638: Ech0 authenticated user-list exposed data via public `/api/allusers` endpoint

> Unauthenticated attackers can access the public /api/allusers endpoint to enumerate users and view profile metadata in Ech0.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Mar 2026
- **Updated:** 27 Mar 2026
- **Also known as:** GHSA-m983-7426-5hrj, GO-2026-4838

## What is CVE-2026-33638?

CVE-2026-33638 is a medium-severity missing authorization vulnerability in lin-snow Ech0, published on 26 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Ech0 is an open-source, self-hosted publishing platform for personal idea sharing. Prior to version 4.2.0, `GET /api/allusers` is mounted as a public endpoint and returns user records without authentication. This allows remote unauthenticated user enumeration and exposure of user profile metadata. A fix is available in v4.2.0.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-33638?

3 open source packages ship an affected version, including github.com/lin-snow/ech0. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/lin-snow/ech0` | Go | All versions | 1.4.8-0.20260322121226-acbf1fd71011 |
| `github.com/lin-snow/ech0` | Go | All versions | 1.4.8-0.20260322121226-acbf1fd71011 |
| `github.com/lin-snow/ech0` | Go | All versions | 1.4.8-0.20260322121226-acbf1fd71011 |

Products: Ech0 Ech0.

## How do I fix CVE-2026-33638?

Upgrade github.com/lin-snow/ech0 to 1.4.8-0.20260322121226-acbf1fd71011 or later.

## Is CVE-2026-33638 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33638 exists.

## Other vulnerabilities in lin-snow Ech0

- [CVE-2026-35036](https://insights.sbomify.com/CVE-2026-35036/): Ech0 Affected by Unauthenticated Server-Side Request Forgery in Website Preview Feature (high 7.5)
- [CVE-2026-35037](https://insights.sbomify.com/CVE-2026-35037/): Ech0 affected by unauthenticated SSRF in GetWebsiteTitle allows access to internal services and cloud metadata (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33638 and fix it if it is affected.

What it is: CVE-2026-33638 is a medium-severity missing authorization vulnerability in lin-snow Ech0, published on 26 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33638 exists.

Affected packages and fixed versions:
- github.com/lin-snow/ech0 (Go): affected all versions; fixed in 1.4.8-0.20260322121226-acbf1fd71011
- github.com/lin-snow/ech0 (Go): affected all versions; fixed in 1.4.8-0.20260322121226-acbf1fd71011
- github.com/lin-snow/ech0 (Go): affected all versions; fixed in 1.4.8-0.20260322121226-acbf1fd71011

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33638/ (Markdown: https://insights.sbomify.com/CVE-2026-33638/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33638
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33638
- OSV: https://osv.dev/vulnerability/CVE-2026-33638

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33638/
Summaries are generated and may contain mistakes; the official description above is the record.
