{"answers":{"affected":"3 open source packages ship an affected version, including glances and Glances. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33641 exists.","fix":"Upgrade glances to 4.5.3 or later.","what":"CVE-2026-33641 is a high-severity command injection vulnerability in nicolargo glances, published on 2 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-33641 and fix it if it is affected.\n\nWhat it is: CVE-2026-33641 is a high-severity command injection vulnerability in nicolargo glances, published on 2 Apr 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33641 exists.\n\nAffected packages and fixed versions:\n- glances (PyPI): affected all versions; fixed in 4.5.3\n- glances (PyPI): affected all versions; fixed in 4.5.3\n- Glances (PyPI): affected all versions; fixed in 4.5.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-33641/ (Markdown: https://insights.sbomify.com/CVE-2026-33641/index.md)","id":"CVE-2026-33641","markdown":"https://insights.sbomify.com/CVE-2026-33641/index.md","name":"CVE-2026-33641","record":{"aliases":["DEBIAN-CVE-2026-33641","GHSA-qhj7-v7h7-q4c7","PYSEC-2026-2174","UBUNTU-CVE-2026-33641"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"System monitoring tool","requires_auth":"low_privilege","summary":"Attackers with configuration file access can execute arbitrary commands via backtick syntax, potentially escalating privileges in elevated deployments.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"glances","vendor":"nicolargo"}],"cvss":{"score":7.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Glances is an open-source system cross-platform monitoring tool. Prior to version 4.5.3, Glances supports dynamic configuration values in which substrings enclosed in backticks are executed as system commands during configuration parsing. This behavior occurs in Config.get_value() and is implemented without validation or restriction of the executed commands. If an attacker can modify or influence configuration files, arbitrary commands will execute automatically with the privileges of the Glances process during startup or configuration reload. In deployments where Glances runs with elevated privileges (e.g., as a system service), this may lead to privilege escalation. This issue has been patched in version 4.5.3.","ecosystems":["PyPI"],"exploits":{"exploitdb":1,"first_seen":"2026-05-13","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-05-13","kind":"exploitdb","ref":"52559","stars":null,"title":"glances 4.5.2 - command injection"}],"tier":"weaponised"},"has_fix":true,"headline":"Glances Vulnerable to Command Injection via Dynamic Configuration Values","id":"CVE-2026-33641","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":3,"n_references":3,"next":{"headline":"Kitty has a Heap Buffer Over-Read/Write via Integer Overflow in compose_rectangles Bounds Check","id":"CVE-2026-33642"},"packages":[{"ecosystem":"PyPI","fixed":["4.5.3"],"introduced":["0"],"last_affected":[],"package":"Glances","purl":null,"source":"GHSA-qhj7-v7h7-q4c7"},{"ecosystem":"PyPI","fixed":["4.5.3"],"introduced":["0"],"last_affected":[],"package":"glances","purl":"pkg:pypi/glances","source":"GHSA-qhj7-v7h7-q4c7"},{"ecosystem":"PyPI","fixed":["4.5.3"],"introduced":["0"],"last_affected":[],"package":"glances","purl":"pkg:pypi/glances","source":"PYSEC-2026-2174"}],"prev":{"headline":"Outline has a rate limit bypass that allows brute force of email login OTP","id":"CVE-2026-33640"},"products":["glances"],"published":"2026-04-02","related":[{"cvss_score":9.1,"headline":"Glances's Browser API Exposes Reusable Downstream Credentials via `/api/4/serverslist`","id":"CVE-2026-32633","kev_date_added":null,"published":"2026-03-18"},{"cvss_score":8.7,"headline":"Glances exposes the REST API without authentication","id":"CVE-2026-32596","kev_date_added":null,"published":"2026-03-18"},{"cvss_score":8.7,"headline":"Glances Exposes Unauthenticated Configuration Secrets","id":"CVE-2026-30928","kev_date_added":null,"published":"2026-03-10"},{"cvss_score":8.1,"headline":"Glances's Default CORS Configuration Allows Cross-Origin Credential Theft","id":"CVE-2026-32610","kev_date_added":null,"published":"2026-03-18"},{"cvss_score":8.1,"headline":"Glances Central Browser Autodiscovery Leaks Reusable Credentials to Zeroconf-Spoofed Servers","id":"CVE-2026-32634","kev_date_added":null,"published":"2026-03-18"},{"cvss_score":7.7,"headline":"Glances Vulnerable to Cross-Origin Information Disclosure via Unauthenticated REST API (/api/4) due to Permissive CORS","id":"CVE-2026-34839","kev_date_added":null,"published":"2026-04-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-04-02","vendors":["nicolargo"]},"summary":"Attackers with configuration file access can execute arbitrary commands via backtick syntax, potentially escalating privileges in elevated deployments.","url":"https://insights.sbomify.com/CVE-2026-33641/"}