CVE-2026-33642 Kitty has a Heap Buffer Over-Read/Write via Integer Overflow in compose_rectangles Bounds Check

Critical 9.9 Published Updated

An attacker can trigger heap buffer over-read/write in Kitty terminal via integer overflow in graphics composition, potentially leading to code execution.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-33642?

CVE-2026-33642 is a critical vulnerability in kovidgoyal kitty, published on 19 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Kitty is a cross-platform GPU based terminal. In versions 0.46.2 and below, the handle_compose_command() function in kitty/graphics.c performs bounds validation on composition offsets using unsigned 32-bit arithmetic that is subject to integer wrapping, potentially leading to Heap Buffer Over-Read/Write. An attacker who can write escape sequences to a kitty terminal (e.g., via a malicious file, SSH login banner, or piped content) can supply crafted x_offset/y_offset values that pass the bounds check after wrapping but cause massive out-of-bounds heap memory access in compose_rectangles(). No user interaction is required. No non-default configuration is required. The attacker only needs the ability to produce output in a kitty terminal window. This issue has been fixed in version 0.47.0.

Weakness: CWE-787, CWE-190, CWE-125

Which versions are affected by CVE-2026-33642?

It affects 1 product.

Products include Kovidgoyal Kitty.

How do I fix CVE-2026-33642?

Upgrade to a fixed version.

Is CVE-2026-33642 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33642 exists.

Sources

Also known as DEBIAN-CVE-2026-33642, GHSA-qfgm-2c64-6x3x, UBUNTU-CVE-2026-33642.

Is CVE-2026-33642 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free