# CVE-2026-33657: EspoCRM: Stored HTML injection in email notifications about stream notes via unescaped post field

> Authenticated users can inject HTML into email notifications via stream notes, enabling phishing and tracking against recipients.

- **Severity:** Medium 4.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 13 Apr 2026
- **Updated:** 13 Apr 2026
- **Also known as:** GHSA-8prm-r5j9-j574

## What is CVE-2026-33657?

CVE-2026-33657 is a medium-severity cross-site scripting vulnerability in espocrm, published on 13 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

EspoCRM is an open source customer relationship management application. Versions 9.3.3 and below have a stored HTML injection vulnerability that allows any authenticated user with standard (non-administrative) privileges to inject arbitrary HTML into system-generated email notifications by crafting malicious content in the post field of stream activity notes. The vulnerability exists because server-side Handlebars templates render the post field using unescaped triple-brace syntax, the Markdown processor preserves inline HTML by default, and the rendering pipeline explicitly skips sanitization for fields present in additionalData, creating a path where attacker-controlled HTML is accepted, stored, and rendered directly into emails without any escaping. Since the emails are sent using the system's configured SMTP identity (such as an administrative sender address), the injected content appears fully trusted to recipients, enabling phishing attacks, user tracking via embedded resources like image beacons, and UI manipulation within email content. The @mention feature further increases the impact by allowing targeted delivery of malicious emails to specific users. This issue has been fixed in version 9.3.4.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page), CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2026-33657?

It affects 1 product.


Products: Espocrm Espocrm.

## How do I fix CVE-2026-33657?

No fix has been published for CVE-2026-33657 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-33657 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33657 exists.

Public exploit code:

- EspoCRM 9.3.3 - Stored HTML Injection in Email Notifications (github_poc): https://github.com/EntroVyx/CVE-2026-33657

## Other vulnerabilities in espocrm

- [CVE-2014-7985](https://insights.sbomify.com/CVE-2014-7985/): Path traversal in n/a (critical 10.0)
- [CVE-2026-33656](https://insights.sbomify.com/CVE-2026-33656/): Path traversal in espocrm (critical 9.1)
- [CVE-2022-38843](https://insights.sbomify.com/CVE-2022-38843/): File upload in n/a (high 8.8)
- [CVE-2019-14351](https://insights.sbomify.com/CVE-2019-14351/): Information disclosure in n/a (high 8.8)
- [CVE-2020-37094](https://insights.sbomify.com/CVE-2020-37094/): EspoCRM 5.7.0 < 5.9.0 - Two-Factor Authentication Bypass via Auth Token Reuse Between Accounts with Identical Passwords (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33657 and fix it if it is affected.

What it is: CVE-2026-33657 is a medium-severity cross-site scripting vulnerability in espocrm, published on 13 Apr 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33657 exists.

Affected product: espocrm. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33657/ (Markdown: https://insights.sbomify.com/CVE-2026-33657/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33657
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33657
- OSV: https://osv.dev/vulnerability/CVE-2026-33657

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33657/
Summaries are generated and may contain mistakes; the official description above is the record.
