CVE-2026-33658 Rails Active Storage has a possible DoS vulnerability in proxy mode via multi-range requests

Low 2.3 Published Updated

Attackers can cause denial of service in Rails Active Storage proxy mode by sending HTTP requests with excessive byte ranges, consuming disproportionate CPU resources.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-33658?

CVE-2026-33658 is a low-severity denial of service vulnerability in Rubyonrails Rails, published on 26 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Active Storage allows users to attach cloud and local files in Rails applications. Prior to versions 8.1.2.1, 8.0.4.1, and 7.2.3.1 Active Storage's proxy controller does not limit the number of byte ranges in an HTTP Range header. A request with thousands of small ranges causes disproportionate CPU usage compared to a normal request for the same file, possibly resulting in a DoS vulnerability. Versions 8.1.2.1, 8.0.4.1, and 7.2.3.1 contain a patch.

Weakness: CWE-770

Which versions are affected by CVE-2026-33658?

6 open source packages ship an affected version, including activestorage. It affects 1 product.

PackageAffectedFixed in
activestorage RubyGemsAll versions7.2.3.1
activestorage RubyGemsAll versions7.2.3.1
activestorage RubyGemsFrom 8.0.08.0.4.1
activestorage RubyGemsFrom 8.0.08.0.4.1
activestorage RubyGemsFrom 8.1.08.1.2.1
activestorage RubyGemsFrom 8.1.08.1.2.1

Products include Rubyonrails Rails.

How do I fix CVE-2026-33658?

Upgrade activestorage to a fixed version for your release line: 7.2.3.1, 8.0.4.1 or 8.1.2.1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-33658 being exploited?

There is no known exploitation of CVE-2026-33658 in the wild and no public exploit code.

All Rubyonrails Rails vulnerabilities

Sources

Also known as DEBIAN-CVE-2026-33658, GHSA-p9fm-f462-ggrg, UBUNTU-CVE-2026-33658.

Is CVE-2026-33658 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free