# CVE-2026-33658: Rails Active Storage has a possible DoS vulnerability in proxy mode via multi-range requests

> Attackers can cause denial of service in Rails Active Storage proxy mode by sending HTTP requests with excessive byte ranges, consuming disproportionate CPU resources.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Mar 2026
- **Updated:** 30 Mar 2026
- **Also known as:** DEBIAN-CVE-2026-33658, GHSA-p9fm-f462-ggrg, UBUNTU-CVE-2026-33658

## What is CVE-2026-33658?

CVE-2026-33658 is a low-severity denial of service vulnerability in Rubyonrails Rails, published on 26 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Active Storage allows users to attach cloud and local files in Rails applications. Prior to versions 8.1.2.1, 8.0.4.1, and 7.2.3.1
Active Storage's proxy controller does not limit the number of byte ranges in an HTTP Range header. A request with thousands of small ranges causes disproportionate CPU usage compared to a normal request for the same file, possibly resulting in a DoS vulnerability. Versions 8.1.2.1, 8.0.4.1, and 7.2.3.1 contain a patch.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-33658?

6 open source packages ship an affected version, including activestorage. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `activestorage` | RubyGems | All versions | 7.2.3.1 |
| `activestorage` | RubyGems | All versions | 7.2.3.1 |
| `activestorage` | RubyGems | From 8.0.0 | 8.0.4.1 |
| `activestorage` | RubyGems | From 8.0.0 | 8.0.4.1 |
| `activestorage` | RubyGems | From 8.1.0 | 8.1.2.1 |
| `activestorage` | RubyGems | From 8.1.0 | 8.1.2.1 |

Products: Rubyonrails Rails.

## How do I fix CVE-2026-33658?

Upgrade activestorage to a fixed version for your release line: 7.2.3.1, 8.0.4.1 or 8.1.2.1.

## Is CVE-2026-33658 being exploited?

There is no known exploitation of CVE-2026-33658 in the wild and no public exploit code.

## Other vulnerabilities in Rubyonrails Rails

- [CVE-2013-0277](https://insights.sbomify.com/CVE-2013-0277/): Active Record contains deserialization of arbitrary YAML (critical 10.0)
- [CVE-2017-17916](https://insights.sbomify.com/CVE-2017-17916/): SQL injection in n/a (high 8.1)
- [CVE-2017-17917](https://insights.sbomify.com/CVE-2017-17917/): SQL injection in n/a (high 8.1)
- [CVE-2026-33195](https://insights.sbomify.com/CVE-2026-33195/): Rails Active Storage has possible Path Traversal in DiskService (high 8.0)
- [CVE-2024-26142](https://insights.sbomify.com/CVE-2024-26142/): Rails possible ReDoS vulnerability in Accept header parsing in Action Dispatch (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33658 and fix it if it is affected.

What it is: CVE-2026-33658 is a low-severity denial of service vulnerability in Rubyonrails Rails, published on 26 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33658 in the wild and no public exploit code.

Affected packages and fixed versions:
- activestorage (RubyGems): affected all versions; fixed in 7.2.3.1
- activestorage (RubyGems): affected all versions; fixed in 7.2.3.1
- activestorage (RubyGems): affected from 8.0.0; fixed in 8.0.4.1
- activestorage (RubyGems): affected from 8.0.0; fixed in 8.0.4.1
- activestorage (RubyGems): affected from 8.1.0; fixed in 8.1.2.1
- activestorage (RubyGems): affected from 8.1.0; fixed in 8.1.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33658/ (Markdown: https://insights.sbomify.com/CVE-2026-33658/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33658
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33658
- OSV: https://osv.dev/vulnerability/CVE-2026-33658

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33658/
Summaries are generated and may contain mistakes; the official description above is the record.
