CVE-2026-33660 n8n Has Multiple Remote Code Execution Vulnerabilities in Merge Node AlaSQL SQL Mode

Critical 9.4 Published Updated

Authenticated users can achieve remote code execution and read local files via SQL injection in the Merge node's AlaSQL mode.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-33660?

CVE-2026-33660 is a critical code injection vulnerability in N8n N8n, published on 25 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

n8n is an open source workflow automation platform. Prior to versions 2.14.1, 2.13.3, and 1.123.26, an authenticated user with permission to create or modify workflows could use the Merge node's "Combine by SQL" mode to read local files on the n8n host and achieve remote code execution. The AlaSQL sandbox did not sufficiently restrict certain SQL statements, allowing an attacker to access sensitive files on the server or even compromise the instance. The issue has been fixed in n8n versions 2.14.1, 2.13.3, and 1.123.26. Users should upgrade to one of these versions or later to remediate the vulnerability. If upgrading is not immediately possible, administrators should consider the following temporary mitigations: Limit workflow creation and editing permissions to fully trusted users only, and/or disable the Merge node by adding `n8n-nodes-base.merge` to the `NODES_EXCLUDE` environment variable. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.

Weakness: CWE-89, CWE-94

Which versions are affected by CVE-2026-33660?

6 open source packages ship an affected version, including n8n. It affects 1 product.

PackageAffectedFixed in
n8n npmAll versions1.123.27
n8n npmAll versions1.123.27
n8n npmFrom 2.0.0-rc.02.13.3
n8n npmFrom 2.0.0-rc.02.13.3
n8n npmFrom 2.14.02.14.1
n8n npmFrom 2.14.02.14.1

Products include N8n N8n.

How do I fix CVE-2026-33660?

Upgrade n8n to a fixed version for your release line: 1.123.27, 2.13.3 or 2.14.1.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-33660 being exploited?

There is no known exploitation of CVE-2026-33660 in the wild and no public exploit code.

All N8n N8n vulnerabilities

Sources

Also known as GHSA-58qr-rcgv-642v.

Is CVE-2026-33660 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free