# CVE-2026-33665: n8n: LDAP Email-Based Account Linking Allows Privilege Escalation and Account Takeover

> Authenticated LDAP users can take over other accounts, including admins, by matching email attributes, requiring LDAP configuration.

- **Severity:** High 8.8 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:H/SI:H/SA:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Mar 2026
- **Updated:** 27 Mar 2026
- **Also known as:** GHSA-c545-x2rh-82fc

## What is CVE-2026-33665?

CVE-2026-33665 is a high-severity authentication bypass vulnerability in N8n N8n, published on 25 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

n8n is an open source workflow automation platform. Prior to versions 2.4.0 and 1.121.0, when LDAP authentication is enabled, n8n automatically linked an LDAP identity to an existing local account if the LDAP email attribute matched the local account's email. An authenticated LDAP user who could control their own LDAP email attribute could set it to match another user's email — including an administrator's — and upon login gain full access to that account. The account linkage persisted even if the LDAP email was later reverted, resulting in a permanent account takeover. LDAP authentication must be configured and active (non-default). The issue has been fixed in n8n versions 2.4.0 and 1.121.0. Users should upgrade to one of these versions or later to remediate the vulnerability. If upgrading is not immediately possible, administrators should consider the following temporary mitigations: Disable LDAP authentication until the instance can be upgraded, restrict LDAP directory permissions so that users cannot modify their own email attributes, and/or audit existing LDAP-linked accounts for unexpected account associations. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-33665?

4 open source packages ship an affected version, including n8n. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `n8n` | npm | All versions | 1.121.0 |
| `n8n` | npm | All versions | 1.121.0 |
| `n8n` | npm | From 2.0.0-rc.0 | 2.4.0 |
| `n8n` | npm | From 2.0.0-rc.0 | 2.4.0 |

Products: N8n N8n.

## How do I fix CVE-2026-33665?

Upgrade n8n to a fixed version for your release line: 1.121.0 or 2.4.0.

## Is CVE-2026-33665 being exploited?

There is no known exploitation of CVE-2026-33665 in the wild and no public exploit code.

## Other vulnerabilities in N8n N8n

- [CVE-2025-68613](https://insights.sbomify.com/CVE-2025-68613/): n8n Improper Control of Dynamically-Managed Code Resources (critical 10.0, exploited in the wild)
- [CVE-2026-21877](https://insights.sbomify.com/CVE-2026-21877/): n8n is vulnerable to Remote Code Execution via Arbitrary File Write (critical 10.0)
- [CVE-2026-21858](https://insights.sbomify.com/CVE-2026-21858/): n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling (critical 10.0)
- [CVE-2026-1470](https://insights.sbomify.com/CVE-2026-1470/): n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution (critical 9.9)
- [CVE-2025-68668](https://insights.sbomify.com/CVE-2025-68668/): n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33665 and fix it if it is affected.

What it is: CVE-2026-33665 is a high-severity authentication bypass vulnerability in N8n N8n, published on 25 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33665 in the wild and no public exploit code.

Affected packages and fixed versions:
- n8n (npm): affected all versions; fixed in 1.121.0
- n8n (npm): affected all versions; fixed in 1.121.0
- n8n (npm): affected from 2.0.0-rc.0; fixed in 2.4.0
- n8n (npm): affected from 2.0.0-rc.0; fixed in 2.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33665/ (Markdown: https://insights.sbomify.com/CVE-2026-33665/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33665
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33665
- OSV: https://osv.dev/vulnerability/CVE-2026-33665

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33665/
Summaries are generated and may contain mistakes; the official description above is the record.
