# CVE-2026-33666: Zserio: Integer Overflow in BitStreamReader on 32-bit platforms

> An integer overflow in Zserio's BitStreamReader allows attackers to cause a segmentation fault and denial of service on 32-bit platforms.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 24 Apr 2026
- **Updated:** 27 Apr 2026
- **Also known as:** GHSA-fjwv-6wcr-vqwj

## What is CVE-2026-33666?

CVE-2026-33666 is a high-severity vulnerability in ndsev zserio, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Zserio is a framework for serializing structured data with a compact and efficient way with low overhead. Prior to 2.18.1, in BitStreamReader.h readBytes() / readString(), the setBitPosition() bounds check receives the overflowed value and is completely bypassed. The code then reads len bytes (512 MB) from a buffer that is only a few bytes long, causing a segmentation fault. This vulnerability is fixed in 2.18.1.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2026-33666?

It affects 1 product.


Products: Nds-Association Zserio.

## How do I fix CVE-2026-33666?

No fix has been published for CVE-2026-33666 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-33666 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33666 exists.

## Other vulnerabilities in ndsev zserio

- [CVE-2026-33524](https://insights.sbomify.com/CVE-2026-33524/): Zserio: Integer Overflow in BitStreamReader and Unbounded Memory Allocation in Deserialization (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33666 and fix it if it is affected.

What it is: CVE-2026-33666 is a high-severity vulnerability in ndsev zserio, published on 24 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33666 exists.

Affected product: ndsev zserio. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33666/ (Markdown: https://insights.sbomify.com/CVE-2026-33666/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33666
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33666
- OSV: https://osv.dev/vulnerability/CVE-2026-33666

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33666/
Summaries are generated and may contain mistakes; the official description above is the record.
