CVE-2026-33671 Picomatch has a ReDoS vulnerability via extglob quantifiers

High 7.5 Published Updated

Attackers can cause denial of service via catastrophic backtracking in picomatch when processing crafted extglob patterns from untrusted input.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-33671?

CVE-2026-33671 is a high-severity denial of service vulnerability in micromatch picomatch, published on 26 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Picomatch is a glob matcher written JavaScript. Versions prior to 4.0.4, 3.0.2, and 2.3.2 are vulnerable to Regular Expression Denial of Service (ReDoS) when processing crafted extglob patterns. Certain patterns using extglob quantifiers such as `+()` and `*()`, especially when combined with overlapping alternatives or nested extglobs, are compiled into regular expressions that can exhibit catastrophic backtracking on non-matching input. Applications are impacted when they allow untrusted users to supply glob patterns that are passed to `picomatch` for compilation or matching. In those cases, an attacker can cause excessive CPU consumption and block the Node.js event loop, resulting in a denial of service. Applications that only use trusted, developer-controlled glob patterns are much less likely to be exposed in a security-relevant way. This issue is fixed in picomatch 4.0.4, 3.0.2 and 2.3.2. Users should upgrade to one of these versions or later, depending on their supported release line. If upgrading is not immediately possible, avoid passing untrusted glob patterns to `picomatch`. Possible mitigations include disabling extglob support for untrusted patterns by using `noextglob: true`, rejecting or sanitizing patterns containing nested extglobs or extglob quantifiers such as `+()` and `*()`, enforcing strict allowlists for accepted pattern syntax, running matching in an isolated worker or separate process with time and resource limits, and applying application-level request throttling and input validation for any endpoint that accepts glob patterns.

Weakness: CWE-1333

Which versions are affected by CVE-2026-33671?

6 open source packages ship an affected version, including picomatch. It affects 1 product.

PackageAffectedFixed in
picomatch npmAll versions2.3.2
picomatch npmAll versions2.3.2
picomatch npmFrom 3.0.03.0.2
picomatch npmFrom 3.0.03.0.2
picomatch npmFrom 4.0.04.0.4
picomatch npmFrom 4.0.04.0.4

Products include Jonschlinkert Picomatch.

How do I fix CVE-2026-33671?

Upgrade picomatch to a fixed version for your release line: 2.3.2, 3.0.2 or 4.0.4.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-33671 being exploited?

There is no known exploitation of CVE-2026-33671 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

Sources

Also known as AZL-81026, AZL-81035, CLEANSTART-2026-JT00262, CLEANSTART-2026-KS09022, CLEANSTART-2026-QN85900, CLEANSTART-2026-WP30265 and 33 more.

Is CVE-2026-33671 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free