# CVE-2026-33671: Picomatch has a ReDoS vulnerability via extglob quantifiers

> Attackers can cause denial of service via catastrophic backtracking in picomatch when processing crafted extglob patterns from untrusted input.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Mar 2026
- **Updated:** 27 Mar 2026
- **Also known as:** AZL-81026, AZL-81035, CLEANSTART-2026-JT00262, CLEANSTART-2026-KS09022, CLEANSTART-2026-QN85900, CLEANSTART-2026-WP30265, CLEANSTART-2026-YA15399, DEBIAN-CVE-2026-33671, GHSA-c2c7-rcm5-vvqj, MINI-25mr-fr99-4wqh, MINI-33rg-xg6v-f8r7, MINI-3776-whgr-g7r4, MINI-3rw2-53j7-495v, MINI-5269-87cc-g6qw, MINI-535m-c8ph-v5px, MINI-5g7m-gjmp-w9qh, MINI-5hq2-84jg-f758, MINI-6gfm-g5w9-g63h, MINI-6rr5-h52p-f6vp, MINI-6w5f-mgxj-c7mw, MINI-8h5w-9q62-j72r, MINI-8rwm-f636-ggrg, MINI-8w84-7qw6-pcp6, MINI-f67m-7837-5rh9, MINI-gjg6-v6gh-3cjj, MINI-hfhj-jfvf-xwhh, MINI-hhq3-vj2g-75c6, MINI-hx37-mcvf-jvjp, MINI-j773-82mj-4pwx, MINI-qh83-h27v-www6, MINI-rv64-8h56-v35q, MINI-v79h-vv76-qfp9, MINI-vrw2-mfxg-627g, MINI-wcp5-vhr6-pp5r, MINI-wjfx-572x-gg52, MINI-wwhc-x7fr-xqq2, MINI-xx49-gh3m-25m7, ROOT-APP-NPM-CVE-2026-33671, UBUNTU-CVE-2026-33671

## What is CVE-2026-33671?

CVE-2026-33671 is a high-severity denial of service vulnerability in micromatch picomatch, published on 26 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Picomatch is a glob matcher written JavaScript. Versions prior to 4.0.4, 3.0.2, and 2.3.2 are vulnerable to Regular Expression Denial of Service (ReDoS) when processing crafted extglob patterns. Certain patterns using extglob quantifiers such as `+()` and `*()`, especially when combined with overlapping alternatives or nested extglobs, are compiled into regular expressions that can exhibit catastrophic backtracking on non-matching input. Applications are impacted when they allow untrusted users to supply glob patterns that are passed to `picomatch` for compilation or matching. In those cases, an attacker can cause excessive CPU consumption and block the Node.js event loop, resulting in a denial of service. Applications that only use trusted, developer-controlled glob patterns are much less likely to be exposed in a security-relevant way. This issue is fixed in picomatch 4.0.4, 3.0.2 and 2.3.2. Users should upgrade to one of these versions or later, depending on their supported release line. If upgrading is not immediately possible, avoid passing untrusted glob patterns to `picomatch`. Possible mitigations include disabling extglob support for untrusted patterns by using `noextglob: true`, rejecting or sanitizing patterns containing nested extglobs or extglob quantifiers such as `+()` and `*()`, enforcing strict allowlists for accepted pattern syntax, running matching in an isolated worker or separate process with time and resource limits, and applying application-level request throttling and input validation for any endpoint that accepts glob patterns.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2026-33671?

6 open source packages ship an affected version, including picomatch. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `picomatch` | npm | All versions | 2.3.2 |
| `picomatch` | npm | All versions | 2.3.2 |
| `picomatch` | npm | From 3.0.0 | 3.0.2 |
| `picomatch` | npm | From 3.0.0 | 3.0.2 |
| `picomatch` | npm | From 4.0.0 | 4.0.4 |
| `picomatch` | npm | From 4.0.0 | 4.0.4 |

Products: Jonschlinkert Picomatch.

## How do I fix CVE-2026-33671?

Upgrade picomatch to a fixed version for your release line: 2.3.2, 3.0.2 or 4.0.4.

## Is CVE-2026-33671 being exploited?

There is no known exploitation of CVE-2026-33671 in the wild and no public exploit code.

Public exploit code:

- Minimal repro for Next.js 16.2.4 bundling picomatch 4.0.3 (CVE-2026-33671) (github_poc): https://github.com/BeLazy167/next-picomatch-cve-repro

## Other vulnerabilities in micromatch picomatch

- [CVE-2026-33672](https://insights.sbomify.com/CVE-2026-33672/): Picomatch: Method Injection in POSIX Character Classes causes incorrect Glob Matching (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33671 and fix it if it is affected.

What it is: CVE-2026-33671 is a high-severity denial of service vulnerability in micromatch picomatch, published on 26 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33671 in the wild and no public exploit code.

Affected packages and fixed versions:
- picomatch (npm): affected all versions; fixed in 2.3.2
- picomatch (npm): affected all versions; fixed in 2.3.2
- picomatch (npm): affected from 3.0.0; fixed in 3.0.2
- picomatch (npm): affected from 3.0.0; fixed in 3.0.2
- picomatch (npm): affected from 4.0.0; fixed in 4.0.4
- picomatch (npm): affected from 4.0.0; fixed in 4.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33671/ (Markdown: https://insights.sbomify.com/CVE-2026-33671/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33671
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33671
- OSV: https://osv.dev/vulnerability/CVE-2026-33671

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33671/
Summaries are generated and may contain mistakes; the official description above is the record.
