CVE-2026-33672 Picomatch: Method Injection in POSIX Character Classes causes incorrect Glob Matching
Attackers can inject inherited methods into regex via POSIX classes, causing incorrect glob matching and potential security bypasses in applications using picomatch.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-33672?
CVE-2026-33672 is a medium-severity code injection vulnerability in micromatch picomatch, published on 26 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Picomatch is a glob matcher written JavaScript. Versions prior to 4.0.4, 3.0.2, and 2.3.2 are vulnerable to a method injection vulnerability affecting the `POSIX_REGEX_SOURCE` object. Because the object inherits from `Object.prototype`, specially crafted POSIX bracket expressions (e.g., `[[:constructor:]]`) can reference inherited method names. These methods are implicitly converted to strings and injected into the generated regular expression. This leads to incorrect glob matching behavior (integrity impact), where patterns may match unintended filenames. The issue does not enable remote code execution, but it can cause security-relevant logic errors in applications that rely on glob matching for filtering, validation, or access control. All users of affected `picomatch` versions that process untrusted or user-controlled glob patterns are potentially impacted. This issue is fixed in picomatch 4.0.4, 3.0.2 and 2.3.2. Users should upgrade to one of these versions or later, depending on their supported release line. If upgrading is not immediately possible, avoid passing untrusted glob patterns to picomatch. Possible mitigations include sanitizing or rejecting untrusted glob patterns, especially those containing POSIX character classes like `[[:...:]]`; avoiding the use of POSIX bracket expressions if user input is involved; and manually patching the library by modifying `POSIX_REGEX_SOURCE` to use a null prototype.
Weakness: CWE-1321
Which versions are affected by CVE-2026-33672?
6 open source packages ship an affected version, including picomatch. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
picomatch npm | All versions | 2.3.2 |
picomatch npm | All versions | 2.3.2 |
picomatch npm | From 3.0.0 | 3.0.2 |
picomatch npm | From 3.0.0 | 3.0.2 |
picomatch npm | From 4.0.0 | 4.0.4 |
picomatch npm | From 4.0.0 | 4.0.4 |
Products include Jonschlinkert Picomatch.
How do I fix CVE-2026-33672?
Upgrade picomatch to a fixed version for your release line: 2.3.2, 3.0.2 or 4.0.4.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-33672 being exploited?
There is no known exploitation of CVE-2026-33672 in the wild and no public exploit code.
Other vulnerabilities in micromatch picomatch
Sources
Also known as AZL-81023, AZL-81038, CLEANSTART-2026-LA61588, CLEANSTART-2026-LU58636, CLEANSTART-2026-RI19788, CLEANSTART-2026-SS22483 and 32 more.