CVE-2026-33673 PrestaShop has multiple stored XSS vulnerabilities via unprotected Template variables

High 7.7 Published Updated

Attackers with back-office access can inject malicious scripts into PrestaShop templates, leading to code execution or account takeover.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-33673?

CVE-2026-33673 is a high-severity cross-site scripting vulnerability in Prestashop Prestashop, published on 26 Mar 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

PrestaShop is an open source e-commerce web application. Versions prior to 8.2.5 and 9.1.0 are vulnerable to stored Cross-Site Scripting (stored XSS) vulnerabilities in the BO. An attacker who can inject data into the database, via limited back-office access or a previously existing vulnerability, can exploit unprotected variables in back-office templates. Versions 8.2.5 and 9.1.0 contain a fix. No known workarounds are available.

Weakness: CWE-79

Which versions are affected by CVE-2026-33673?

4 open source packages ship an affected version, including prestashop/prestashop. It affects 1 product.

PackageAffectedFixed in
prestashop/prestashop PackagistAll versions8.2.5
prestashop/prestashop PackagistAll versions8.2.5
prestashop/prestashop PackagistFrom 9.0.0-alpha.19.1.0
prestashop/prestashop PackagistFrom 9.0.0-alpha.19.1.0

Products include Prestashop Prestashop.

How do I fix CVE-2026-33673?

Upgrade prestashop/prestashop to a fixed version for your release line: 8.2.5 or 9.1.0.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-33673 being exploited?

There is no known exploitation of CVE-2026-33673 in the wild and no public exploit code.

All Prestashop Prestashop vulnerabilities

Sources

Also known as GHSA-35pf-37c6-jxjv.

Is CVE-2026-33673 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free