CVE-2026-33674 PrestaShop: Improper Use of Validation Framework
PrestaShop improperly uses its validation framework, potentially allowing unexpected behavior or bypasses in input handling.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-33674?
CVE-2026-33674 is a low-severity vulnerability in Prestashop Prestashop, published on 26 Mar 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
PrestaShop is an open source e-commerce web application. Versions prior to 8.2.5 and 9.1.0 improperly use the validation framework. Versions 8.2.5 and 9.1.0 contain a fix. No known workarounds are available.
Weakness: CWE-1173
Which versions are affected by CVE-2026-33674?
4 open source packages ship an affected version, including prestashop/prestashop. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
prestashop/prestashop Packagist | All versions | 8.2.5 |
prestashop/prestashop Packagist | All versions | 8.2.5 |
prestashop/prestashop Packagist | From 9.0.0-alpha.1 | 9.1.0 |
prestashop/prestashop Packagist | From 9.0.0-alpha.1 | 9.1.0 |
Products include Prestashop Prestashop.
How do I fix CVE-2026-33674?
Upgrade prestashop/prestashop to a fixed version for your release line: 8.2.5 or 9.1.0.
Is CVE-2026-33674 being exploited?
There is no known exploitation of CVE-2026-33674 in the wild and no public exploit code.
Other vulnerabilities in Prestashop Prestashop
Sources
Also known as GHSA-283w-xf3q-788v.