# CVE-2026-33674: PrestaShop: Improper Use of Validation Framework

> PrestaShop improperly uses its validation framework, potentially allowing unexpected behavior or bypasses in input handling.

- **Severity:** Low 2.0 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Mar 2026
- **Updated:** 30 Mar 2026
- **Also known as:** GHSA-283w-xf3q-788v

## What is CVE-2026-33674?

CVE-2026-33674 is a low-severity vulnerability in Prestashop Prestashop, published on 26 Mar 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

PrestaShop is an open source e-commerce web application. Versions prior to 8.2.5 and 9.1.0 improperly use the validation framework. Versions 8.2.5 and 9.1.0 contain a fix. No known workarounds are available.

Weakness: CWE-1173 (Improper Use of Validation Framework)

## Which versions are affected by CVE-2026-33674?

4 open source packages ship an affected version, including prestashop/prestashop. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `prestashop/prestashop` | Packagist | All versions | 8.2.5 |
| `prestashop/prestashop` | Packagist | All versions | 8.2.5 |
| `prestashop/prestashop` | Packagist | From 9.0.0-alpha.1 | 9.1.0 |
| `prestashop/prestashop` | Packagist | From 9.0.0-alpha.1 | 9.1.0 |

Products: Prestashop Prestashop.

## How do I fix CVE-2026-33674?

Upgrade prestashop/prestashop to a fixed version for your release line: 8.2.5 or 9.1.0.

## Is CVE-2026-33674 being exploited?

There is no known exploitation of CVE-2026-33674 in the wild and no public exploit code.

## Other vulnerabilities in Prestashop Prestashop

- [CVE-2023-30839](https://insights.sbomify.com/CVE-2023-30839/): PrestaShop vulnerable to SQL filter bypass leading to arbitrary write requests using "SQL Manager" (critical 10.0)
- [CVE-2008-5791](https://insights.sbomify.com/CVE-2008-5791/): Other in n/a (critical 10.0)
- [CVE-2024-41651](https://insights.sbomify.com/CVE-2024-41651/): Server-side request forgery in n/a (critical 9.8)
- [CVE-2022-31181](https://insights.sbomify.com/CVE-2022-31181/): Remote code execution in prestashop (critical 9.8)
- [CVE-2021-3110](https://insights.sbomify.com/CVE-2021-3110/): SQL injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33674 and fix it if it is affected.

What it is: CVE-2026-33674 is a low-severity vulnerability in Prestashop Prestashop, published on 26 Mar 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-33674 in the wild and no public exploit code.

Affected packages and fixed versions:
- prestashop/prestashop (Packagist): affected all versions; fixed in 8.2.5
- prestashop/prestashop (Packagist): affected all versions; fixed in 8.2.5
- prestashop/prestashop (Packagist): affected from 9.0.0-alpha.1; fixed in 9.1.0
- prestashop/prestashop (Packagist): affected from 9.0.0-alpha.1; fixed in 9.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33674/ (Markdown: https://insights.sbomify.com/CVE-2026-33674/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33674
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33674
- OSV: https://osv.dev/vulnerability/CVE-2026-33674

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33674/
Summaries are generated and may contain mistakes; the official description above is the record.
