# CVE-2026-33687: Sharp has Unrestricted File Upload via Client-Controlled Validation Rules

> Authenticated users can bypass file type restrictions in Sharp by manipulating client-side validation rules, potentially leading to remote code execution if public storage is configured.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Mar 2026
- **Updated:** 27 Mar 2026
- **Also known as:** GHSA-fr76-5637-w3g9

## What is CVE-2026-33687?

CVE-2026-33687 is a high-severity vulnerability in code16 sharp, published on 26 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Sharp is a content management framework built for Laravel as a package. Versions prior to 9.20.0 contain a vulnerability in the file upload endpoint that allows authenticated users to bypass all file type restrictions. The upload endpoint within the `ApiFormUploadController` accepts a client-controlled `validation_rule` parameter. This parameter is directly passed into the Laravel validator without sufficient server-side enforcement. By intercepting the request and sending `validation_rule[]=file`, an attacker can completely bypass all MIME type and file extension restrictions. This issue has been addressed in version 9.20.0 by removing the client-controlled validation rules and strictly defining upload rules server-side. As a workaround, ensure that the storage disk used for Sharp uploads is strictly private. Under default configurations, an attacker cannot directly execute uploaded PHP files unless a public disk configuration is explicitly used.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2026-33687?

2 open source packages ship an affected version, including code16/sharp. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `code16/sharp` | Packagist | All versions | 9.20.0 |
| `code16/sharp` | Packagist | All versions | 9.20.0 |

Products: Code16 Sharp.

## How do I fix CVE-2026-33687?

Upgrade code16/sharp to 9.20.0 or later.

## Is CVE-2026-33687 being exploited?

There is no known exploitation of CVE-2026-33687 in the wild and no public exploit code.

## Other vulnerabilities in code16 sharp

- [CVE-2026-33686](https://insights.sbomify.com/CVE-2026-33686/): Sharp is Vulnerable to Path Traversal via Unsanitized Extension in FileUtil (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33687 and fix it if it is affected.

What it is: CVE-2026-33687 is a high-severity vulnerability in code16 sharp, published on 26 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33687 in the wild and no public exploit code.

Affected packages and fixed versions:
- code16/sharp (Packagist): affected all versions; fixed in 9.20.0
- code16/sharp (Packagist): affected all versions; fixed in 9.20.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33687/ (Markdown: https://insights.sbomify.com/CVE-2026-33687/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33687
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33687
- OSV: https://osv.dev/vulnerability/CVE-2026-33687

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33687/
Summaries are generated and may contain mistakes; the official description above is the record.
