# CVE-2026-33691: OWASP CRS: Whitespace padding in filenames bypasses file upload extension checks

> Attackers can upload malicious files with dangerous extensions by using whitespace padding, bypassing OWASP CRS file upload checks.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Apr 2026
- **Updated:** 18 Apr 2026
- **Also known as:** DEBIAN-CVE-2026-33691, GHSA-rw5f-9w43-gv2w, UBUNTU-CVE-2026-33691, openSUSE-SU-2026:11632-1

## What is CVE-2026-33691?

CVE-2026-33691 is a medium-severity vulnerability in coreruleset, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The OWASP core rule set (CRS) is a set of generic attack detection rules for use with compatible web application firewalls. Prior to versions 3.3.9 and 4.25.0, a bypass was identified in OWASP CRS that allows uploading files with dangerous extensions (.php, .phar, .jsp, .jspx) by inserting whitespace padding in the filename (e.g. photo. php or shell.jsp ). The affected rules do not normalize whitespace before evaluating the file extension regex, so the dot-extension check fails to match. This issue has been patched in versions 3.3.9 and 4.25.0.

Weakness: CWE-178 (Improper Handling of Case Sensitivity)

## Which versions are affected by CVE-2026-33691?

It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `owasp-modsecurity-crs` | openSUSE:Tumbleweed | All versions | 4.29.0-1.1 |

Products: Owasp Owasp Modsecurity Core Rule Set.

## How do I fix CVE-2026-33691?

Upgrade to a fixed version.

## Is CVE-2026-33691 being exploited?

There is no known exploitation of CVE-2026-33691 in the wild and no public exploit code.

## Other vulnerabilities in coreruleset

- [CVE-2026-21876](https://insights.sbomify.com/CVE-2026-21876/): OWASP CRS has multipart bypass using multiple content-type parts (critical 9.3)
- [CVE-2018-16384](https://insights.sbomify.com/CVE-2018-16384/): SQL injection in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33691 and fix it if it is affected.

What it is: CVE-2026-33691 is a medium-severity vulnerability in coreruleset, published on 2 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33691 in the wild and no public exploit code.

Affected product: coreruleset. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33691/ (Markdown: https://insights.sbomify.com/CVE-2026-33691/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33691
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33691
- OSV: https://osv.dev/vulnerability/CVE-2026-33691

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33691/
Summaries are generated and may contain mistakes; the official description above is the record.
