CVE-2026-33713 n8n Vulnerable to SQL Injection in Data Table Node via orderByColumn Expression

High 8.7 Published Updated

Authenticated users can exploit SQL injection in the Data Table node to read, modify, or delete database records, particularly in PostgreSQL deployments.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-33713?

CVE-2026-33713 is a high-severity SQL injection vulnerability in N8n N8n, published on 25 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

n8n is an open source workflow automation platform. Prior to versions 2.14.1, 2.13.3, and 1.123.26, an authenticated user with permission to create or modify workflows could exploit a SQL injection vulnerability in the Data Table Get node. On default SQLite DB, single statements can be manipulated and the attack surface is practically limited. On PostgreSQL deployments, multi-statement execution is possible, enabling data modification and deletion. The issue has been fixed in n8n versions 1.123.26, 2.13.3, and 2.14.1. Users should upgrade to one of these versions or later to remediate the vulnerability. If upgrading is not immediately possible, administrators should consider the following temporary mitigations: Limit workflow creation and editing permissions to fully trusted users only, disable the Data Table node by adding `n8n-nodes-base.dataTable` to the `NODES_EXCLUDE` environment variable, and/or review existing workflows for Data Table Get nodes where `orderByColumn` is set to an expression that incorporates external or user-supplied input. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.

Weakness: CWE-89

Which versions are affected by CVE-2026-33713?

6 open source packages ship an affected version, including n8n. It affects 1 product.

PackageAffectedFixed in
n8n npmAll versions1.123.26
n8n npmAll versions1.123.26
n8n npmFrom 2.0.0-rc.02.13.3
n8n npmFrom 2.0.0-rc.02.13.3
n8n npmFrom 2.14.02.14.1
n8n npmFrom 2.14.02.14.1

Products include N8n N8n.

How do I fix CVE-2026-33713?

Upgrade n8n to a fixed version for your release line: 1.123.26, 2.13.3 or 2.14.1.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2026-33713 being exploited?

There is no known exploitation of CVE-2026-33713 in the wild and no public exploit code.

All N8n N8n vulnerabilities

Sources

Also known as GHSA-98c2-4cr3-4jc3.

Is CVE-2026-33713 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free