# CVE-2026-33718: OpenHands is Vulnerable to Command Injection through its Git Diff Handler

> Authenticated attackers can execute arbitrary commands in the agent sandbox via unsanitized input in the Git diff handler.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Mar 2026
- **Updated:** 27 Mar 2026
- **Also known as:** GHSA-7h8w-hj9j-8rjw, PYSEC-2026-106

## What is CVE-2026-33718?

CVE-2026-33718 is a high-severity command injection vulnerability in OpenHands, published on 27 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenHands is software for AI-driven development. Starting in version 1.5.0, a Command Injection vulnerability exists in the `get_git_diff()` method at `openhands/runtime/utils/git_handler.py:134`. The `path` parameter from the `/api/conversations/{conversation_id}/git/diff` API endpoint is passed unsanitized to a shell command, allowing authenticated attackers to execute arbitrary commands in the agent sandbox. The user is already allowed to instruct the agent to execute commands, but this bypasses the normal channels. Version 1.5.0 fixes the issue.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-33718?

3 open source packages ship an affected version, including openhands-ai. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openhands-ai` | PyPI | All versions | 1.5.0 |
| `openhands-ai` | PyPI | All versions | 1.5.0 |
| `openhands-ai` | PyPI | All versions | 1.5.0 |

Products: Openhands Openhands.

## How do I fix CVE-2026-33718?

Upgrade openhands-ai to 1.5.0 or later.

## Is CVE-2026-33718 being exploited?

There is no known exploitation of CVE-2026-33718 in the wild and no public exploit code.

Public exploit code:

- CVE-2026-33718 (github_poc): https://github.com/HORKimhab/CVE-2026-33718

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33718 and fix it if it is affected.

What it is: CVE-2026-33718 is a high-severity command injection vulnerability in OpenHands, published on 27 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33718 in the wild and no public exploit code.

Affected packages and fixed versions:
- openhands-ai (PyPI): affected all versions; fixed in 1.5.0
- openhands-ai (PyPI): affected all versions; fixed in 1.5.0
- openhands-ai (PyPI): affected all versions; fixed in 1.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33718/ (Markdown: https://insights.sbomify.com/CVE-2026-33718/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33718
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33718
- OSV: https://osv.dev/vulnerability/CVE-2026-33718

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33718/
Summaries are generated and may contain mistakes; the official description above is the record.
