# CVE-2026-33722: n8n Has External Secrets Authorization Bypass in Credential Saving

> Authenticated users can bypass permission checks to retrieve plaintext external secrets by referencing them in credentials, exposing sensitive vault data.

- **Severity:** High 7.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Mar 2026
- **Updated:** 28 Mar 2026
- **Also known as:** GHSA-fxcw-h3qj-8m8p

## What is CVE-2026-33722?

CVE-2026-33722 is a high-severity missing authorization vulnerability in N8n N8n, published on 25 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

n8n is an open source workflow automation platform. Prior to versions 2.6.4 and 1.123.23, an authenticated user without permission to list external secrets could reference a secret by the external name in a credential and retrieve its plaintext value when saving the credential. This bypassed the `externalSecret:list` permission check and allowed access to secrets stored in connected vaults without admin or owner privileges. This issue requires the instance to have an external secrets vault configured. The attacker must know or be able to guess the name of a target secret. The issue has been fixed in n8n versions 1.123.23 and 2.6.4. Users should upgrade to one of these versions or later to remediate the vulnerability. If upgrading is not immediately possible, administrators should consider the following temporary mitigations: Restrict n8n access to fully trusted users only, and/or disable external secrets integration until the patch can be applied. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-33722?

4 open source packages ship an affected version, including n8n. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `n8n` | npm | All versions | 1.123.23 |
| `n8n` | npm | All versions | 1.123.23 |
| `n8n` | npm | From 2.0.0-rc.0 | 2.6.4 |
| `n8n` | npm | From 2.0.0-rc.0 | 2.6.4 |

Products: N8n N8n.

## How do I fix CVE-2026-33722?

Upgrade n8n to a fixed version for your release line: 1.123.23 or 2.6.4.

## Is CVE-2026-33722 being exploited?

There is no known exploitation of CVE-2026-33722 in the wild and no public exploit code.

## Other vulnerabilities in N8n N8n

- [CVE-2025-68613](https://insights.sbomify.com/CVE-2025-68613/): n8n Improper Control of Dynamically-Managed Code Resources (critical 10.0, exploited in the wild)
- [CVE-2026-21877](https://insights.sbomify.com/CVE-2026-21877/): n8n is vulnerable to Remote Code Execution via Arbitrary File Write (critical 10.0)
- [CVE-2026-21858](https://insights.sbomify.com/CVE-2026-21858/): n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling (critical 10.0)
- [CVE-2026-1470](https://insights.sbomify.com/CVE-2026-1470/): n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution (critical 9.9)
- [CVE-2025-68668](https://insights.sbomify.com/CVE-2025-68668/): n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33722 and fix it if it is affected.

What it is: CVE-2026-33722 is a high-severity missing authorization vulnerability in N8n N8n, published on 25 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33722 in the wild and no public exploit code.

Affected packages and fixed versions:
- n8n (npm): affected all versions; fixed in 1.123.23
- n8n (npm): affected all versions; fixed in 1.123.23
- n8n (npm): affected from 2.0.0-rc.0; fixed in 2.6.4
- n8n (npm): affected from 2.0.0-rc.0; fixed in 2.6.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33722/ (Markdown: https://insights.sbomify.com/CVE-2026-33722/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33722
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33722
- OSV: https://osv.dev/vulnerability/CVE-2026-33722

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33722/
Summaries are generated and may contain mistakes; the official description above is the record.
