# CVE-2026-33726: Cilium L7 proxy may bypass Kubernetes NetworkPolicy for same-node traffic

> Attackers can bypass Kubernetes NetworkPolicy restrictions for same-node traffic in specific Cilium configurations, requiring a patch to restore enforcement.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Mar 2026
- **Updated:** 27 Mar 2026
- **Also known as:** BIT-cilium-2026-33726, BIT-cilium-operator-2026-33726, BIT-hubble-relay-2026-33726, CLEANSTART-2026-ZS52141, GHSA-hxv8-4j4r-cqgv, GO-2026-4856, MINI-2fxp-mqfg-j75x, MINI-3fmx-h7pp-c45f, MINI-3pm6-23qx-r2jg, MINI-574g-6vfj-fcf3, MINI-5vvv-m47m-r2c2, MINI-74x5-pq42-68hg, MINI-99q9-5q5f-5x87, MINI-9c77-2pwh-q3g5, MINI-9jh7-q9f7-5jf6, MINI-c774-9pj9-gfxv, MINI-h7q5-2h6f-f7xm, MINI-j2c5-7pmw-p5f4, MINI-mgvf-5865-2c6c, MINI-mwrv-vmvx-6c5j, MINI-pc9q-9966-g2gm, MINI-phx2-j574-wjxq, MINI-q533-fwjj-mxx7, MINI-r43h-2hc3-qvjv

## What is CVE-2026-33726?

CVE-2026-33726 is a medium-severity missing authorization vulnerability in cilium, published on 27 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Cilium is a networking, observability, and security solution with an eBPF-based dataplane. Prior to versions 1.17.14, 1.18.8, and 1.19.2, Ingress Network Policies are not enforced for traffic from pods to L7 Services (Envoy, GAMMA) with a local backend on the same node, when Per-Endpoint Routing is enabled and BPF Host Routing is disabled. Per-Endpoint Routing is disabled by default, but is automatically enabled in deployments using cloud IPAM, including Cilium ENI on EKS (`eni.enabled`), AlibabaCloud ENI (`alibabacloud.enabled`), Azure IPAM (`azure.enabled`, but not AKS BYOCNI), and some GKE deployments (`gke.enabled`; managed offerings such as GKE Dataplane V2 may use different defaults). It is typically not enabled in tunneled deployments, and chaining deployments are not affected. In practice, Amazon EKS with Cilium ENI mode is likely the most common affected environment. Versions 1.17.14, 1.18.8, and 1.19.2 contain a patch. There is currently no officially verified or comprehensive workaround for this issue. The only option would be to disable per-endpoint routes, but this will likely cause disruptions to ongoing connections, and potential conflicts if running in cloud providers.

Weakness: CWE-863 (Incorrect Authorization), CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-33726?

10 open source packages ship an affected version, including github.com/cilium/cilium, cilium and cilium-operator. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cilium/cilium` | Go | All versions | 1.17.14, 1.18.8, 1.19.2 |
| `github.com/cilium/cilium` | Go | All versions | 1.17.14 |
| `github.com/cilium/cilium` | Go | All versions | 1.17.14 |
| `github.com/cilium/cilium` | Go | From 1.18.0 | 1.18.8 |
| `github.com/cilium/cilium` | Go | From 1.18.0 | 1.18.8 |
| `github.com/cilium/cilium` | Go | From 1.19.0 | 1.19.2 |
| `github.com/cilium/cilium` | Go | From 1.19.0 | 1.19.2 |
| `cilium` | Bitnami | All versions | 1.17.14, 1.18.8, 1.19.2 |
| `cilium-operator` | Bitnami | All versions | 1.17.14, 1.18.8, 1.19.2 |
| `hubble-relay` | Bitnami | All versions | 1.17.14, 1.18.8, 1.19.2 |

Products: Cilium Cilium.

## How do I fix CVE-2026-33726?

Upgrade github.com/cilium/cilium to a fixed version for your release line: 1.17.14, 1.18.8 or 1.19.2.

## Is CVE-2026-33726 being exploited?

There is no known exploitation of CVE-2026-33726 in the wild and no public exploit code.

## Other vulnerabilities in cilium

- [CVE-2026-49445](https://insights.sbomify.com/CVE-2026-49445/): Cilium: Sensitive information disclosure and cluster disruption via local Envoy admin socket access (critical 9.2)
- [CVE-2022-29178](https://insights.sbomify.com/CVE-2022-29178/): Incorrect Default Permissions in Cilium (high 8.8)
- [CVE-2024-28860](https://insights.sbomify.com/CVE-2024-28860/): Insecure IPsec transport encryption in Cilium (high 8.0)
- [CVE-2026-41520](https://insights.sbomify.com/CVE-2026-41520/): Cillium exposes sensitive information included in the cilium-bugtool debug archive (high 7.9)
- [CVE-2024-37307](https://insights.sbomify.com/CVE-2024-37307/): Cilium leaks sensitive information in cilium-bugtool (high 7.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33726 and fix it if it is affected.

What it is: CVE-2026-33726 is a medium-severity missing authorization vulnerability in cilium, published on 27 Mar 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33726 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/cilium/cilium (Go): affected all versions; fixed in 1.17.14, 1.18.8, 1.19.2
- github.com/cilium/cilium (Go): affected all versions; fixed in 1.17.14
- github.com/cilium/cilium (Go): affected all versions; fixed in 1.17.14
- github.com/cilium/cilium (Go): affected from 1.18.0; fixed in 1.18.8
- github.com/cilium/cilium (Go): affected from 1.18.0; fixed in 1.18.8
- github.com/cilium/cilium (Go): affected from 1.19.0; fixed in 1.19.2
- github.com/cilium/cilium (Go): affected from 1.19.0; fixed in 1.19.2
- cilium (Bitnami): affected all versions; fixed in 1.17.14, 1.18.8, 1.19.2
- cilium-operator (Bitnami): affected all versions; fixed in 1.17.14, 1.18.8, 1.19.2
- hubble-relay (Bitnami): affected all versions; fixed in 1.17.14, 1.18.8, 1.19.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33726/ (Markdown: https://insights.sbomify.com/CVE-2026-33726/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33726
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33726
- OSV: https://osv.dev/vulnerability/CVE-2026-33726

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33726/
Summaries are generated and may contain mistakes; the official description above is the record.
