{"answers":{"affected":"2 open source packages ship an affected version, including com.datadoghq:dd-java-agent. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-33728 in the wild and no public exploit code.","fix":"Upgrade com.datadoghq:dd-java-agent to 1.60.3 or later.","what":"CVE-2026-33728 is a critical unsafe deserialization vulnerability in DataDog dd-trace-java, published on 27 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-33728 and fix it if it is affected.\n\nWhat it is: CVE-2026-33728 is a critical unsafe deserialization vulnerability in DataDog dd-trace-java, published on 27 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-33728 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.datadoghq:dd-java-agent (Maven): affected from 0.40.0; fixed in 1.60.3\n- com.datadoghq:dd-java-agent (Maven): affected from 0.40.0; fixed in 1.60.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-33728/ (Markdown: https://insights.sbomify.com/CVE-2026-33728/index.md)","id":"CVE-2026-33728","markdown":"https://insights.sbomify.com/CVE-2026-33728/index.md","name":"CVE-2026-33728","record":{"aliases":["GHSA-579q-h82j-r5v2"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Java APM library","requires_auth":"none","summary":"Attacker with network access to RMI/JMX ports on Java 16 or earlier can achieve remote code execution via unsafe deserialization in Datadog dd-trace-java.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"dd-trace-java","vendor":"datadog"}],"cvss":{"score":9.3,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"}],"description":"dd-trace-java is a Datadog APM client for Java. In versions of dd-trace-java 0.40.0 through prior to 1.60.2, the RMI instrumentation registered a custom endpoint that deserialized incoming data without applying serialization filters. On JDK version 16 and earlier, an attacker with network access to a JMX or RMI port on an instrumented JVM could exploit this to potentially achieve remote code execution. All three of the following conditions must be true to exploit this vulnerability: First, dd-trace-java is attached as a Java agent (`-javaagent`) on Java 16 or earlier. Second, a JMX/RMI port has been explicitly configured via `-Dcom.sun.management.jmxremote.port` and is network-reachable, Third, a gadget-chain-compatible library is present on the classpath. For JDK \u003e= 17, no action is required, but upgrading is strongly encouraged. For JDK \u003e= 8u121 \u003c JDK 17, upgrade to dd-trace-java version 1.60.3 or later. For JDK \u003c 8u121 and earlier where serialization filters are not available, apply the workaround. The workaround is to set the following environment variable to disable the RMI integration: `DD_INTEGRATION_RMI_ENABLED=false`.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"dd-trace-java: Unsafe deserialization in RMI instrumentation may lead to remote code execution","id":"CVE-2026-33728","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"deserialization","year":"2026"},"n_packages":2,"n_references":2,"next":{"headline":"OpenFGA has an Authorization Bypass through cached keys","id":"CVE-2026-33729"},"packages":[{"ecosystem":"Maven","fixed":["1.60.3"],"introduced":["0.40.0"],"last_affected":[],"package":"com.datadoghq:dd-java-agent","purl":null,"source":"GHSA-579q-h82j-r5v2"},{"ecosystem":"Maven","fixed":["1.60.3"],"introduced":["0.40.0"],"last_affected":[],"package":"com.datadoghq:dd-java-agent","purl":"pkg:maven/com.datadoghq/dd-java-agent","source":"GHSA-579q-h82j-r5v2"}],"prev":{"headline":"Pi-hole has a Local Privilege Escalation (post-compromise, pihole -\u003e root).","id":"CVE-2026-33727"},"products":["dd-trace-java"],"published":"2026-03-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-03-27","vendors":["DataDog"]},"summary":"Attacker with network access to RMI/JMX ports on Java 16 or earlier can achieve remote code execution via unsafe deserialization in Datadog dd-trace-java.","url":"https://insights.sbomify.com/CVE-2026-33728/"}