# CVE-2026-33729: OpenFGA has an Authorization Bypass through cached keys

> Attackers can bypass authorization checks in OpenFGA when caching is enabled and specific model conditions are used, leading to unauthorized access.

- **Severity:** Medium 5.8 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Mar 2026
- **Updated:** 30 Mar 2026
- **Also known as:** GHSA-h6c8-cww8-35hf, GO-2026-4857, MINI-2p27-m3mg-6hvq, MINI-2vmx-x97v-52c4, MINI-6mp2-jr44-r353, MINI-6x6q-7874-7fph, MINI-76c9-3fwh-w37g, MINI-8659-hx2h-cvp8, MINI-8mx5-599r-j5v4, MINI-9v4f-8hx3-c8gm, MINI-ffm9-whjr-937v, MINI-h6qq-v6fr-5539, MINI-hghj-gxrc-8mrx, MINI-mq59-pcx6-94m7, MINI-mxq3-827h-8pmh, MINI-p2jr-cj4m-mh55, MINI-p4x8-38j4-vj75, MINI-r34w-cwp2-r223, MINI-wf3r-fjhw-3637, MINI-wvjf-r74w-9hq2

## What is CVE-2026-33729?

CVE-2026-33729 is a medium-severity authentication bypass vulnerability in openfga, published on 27 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenFGA is a high-performance and flexible authorization/permission engine built for developers and inspired by Google Zanzibar. In versions prior to 1.13.1, under specific conditions, models using conditions with caching enabled can result in two different check requests producing the same cache key. This can result in OpenFGA reusing an earlier cached result for a different request. Users are affected if the model has relations which rely on condition evaluation andncaching is enabled. OpenFGA v1.13.1 contains a patch.

Weakness: CWE-20 (Improper Input Validation), CWE-345 (Insufficient Verification of Data Authenticity), CWE-1289 (Improper Validation of Unsafe Equivalence in Input)

## Which versions are affected by CVE-2026-33729?

3 open source packages ship an affected version, including github.com/openfga/openfga. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openfga/openfga` | Go | All versions | 1.13.1 |
| `github.com/openfga/openfga` | Go | All versions | 1.13.1 |
| `github.com/openfga/openfga` | Go | All versions | 1.13.1 |

Products: Openfga Openfga.

## How do I fix CVE-2026-33729?

Upgrade github.com/openfga/openfga to 1.13.1 or later.

## Is CVE-2026-33729 being exploited?

There is no known exploitation of CVE-2026-33729 in the wild and no public exploit code.

## Other vulnerabilities in openfga

- [CVE-2024-31452](https://insights.sbomify.com/CVE-2024-31452/): OpenFGA Authorization Bypass (high 8.1)
- [CVE-2022-23542](https://insights.sbomify.com/CVE-2022-23542/): OpenFGA Authorization Bypass (high 7.7)
- [CVE-2024-42473](https://insights.sbomify.com/CVE-2024-42473/): OpenFGA Authorization Bypass (high 7.5)
- [CVE-2026-40293](https://insights.sbomify.com/CVE-2026-40293/): OpenFGA Playground Preshared Key Exposure (medium 6.5)
- [CVE-2023-40579](https://insights.sbomify.com/CVE-2023-40579/): OpenFGA Authorization Bypass (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33729 and fix it if it is affected.

What it is: CVE-2026-33729 is a medium-severity authentication bypass vulnerability in openfga, published on 27 Mar 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-33729 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openfga/openfga (Go): affected all versions; fixed in 1.13.1
- github.com/openfga/openfga (Go): affected all versions; fixed in 1.13.1
- github.com/openfga/openfga (Go): affected all versions; fixed in 1.13.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33729/ (Markdown: https://insights.sbomify.com/CVE-2026-33729/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33729
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33729
- OSV: https://osv.dev/vulnerability/CVE-2026-33729

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33729/
Summaries are generated and may contain mistakes; the official description above is the record.
