# CVE-2026-33744: BentoML has Dockerfile Command Injection via system_packages in bentofile.yaml

> Attackers can execute arbitrary commands during containerization by injecting shell commands into the system_packages field of bentofile.yaml.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Mar 2026
- **Updated:** 27 Mar 2026
- **Also known as:** GHSA-jfjg-vc52-wqvf, PYSEC-2026-157

## What is CVE-2026-33744?

CVE-2026-33744 is a high-severity command injection vulnerability in BentoML, published on 27 Mar 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

BentoML is a Python library for building online serving systems optimized for AI apps and model inference. Prior to 1.4.37, the `docker.system_packages` field in `bentofile.yaml` accepts arbitrary strings that are interpolated directly into Dockerfile `RUN` commands without sanitization. Since `system_packages` is semantically a list of OS package names (data), users do not expect values to be interpreted as shell commands. A malicious `bentofile.yaml` achieves arbitrary command execution during `bentoml containerize` / `docker build`. Version 1.4.37 fixes the issue.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-33744?

3 open source packages ship an affected version, including bentoml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bentoml` | PyPI | All versions | 1.4.37 |
| `bentoml` | PyPI | All versions | 1.4.37 |
| `bentoml` | PyPI | All versions | 1.4.37 |

Products: Bentoml Bentoml.

## How do I fix CVE-2026-33744?

Upgrade bentoml to 1.4.37 or later.

## Is CVE-2026-33744 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33744 exists.

## Other vulnerabilities in BentoML

- [CVE-2025-54381](https://insights.sbomify.com/CVE-2025-54381/): BentoML is Vulnerable to an SSRF Attack Through File Upload Processing (critical 9.9)
- [CVE-2025-32375](https://insights.sbomify.com/CVE-2025-32375/): Insecure Deserialization leads to RCE in BentoML's runner server (critical 9.8)
- [CVE-2025-27520](https://insights.sbomify.com/CVE-2025-27520/): BentoML Allows Remote Code Execution (RCE) via Insecure Deserialization (critical 9.8)
- [CVE-2026-44345](https://insights.sbomify.com/CVE-2026-44345/): BentoML: Dockerfile command injection via docker.base_image (high 8.8)
- [CVE-2026-44346](https://insights.sbomify.com/CVE-2026-44346/): BentoML: Dockerfile command injection via envs[*].name in bentofile.yaml (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33744 and fix it if it is affected.

What it is: CVE-2026-33744 is a high-severity command injection vulnerability in BentoML, published on 27 Mar 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-33744 exists.

Affected packages and fixed versions:
- bentoml (PyPI): affected all versions; fixed in 1.4.37
- bentoml (PyPI): affected all versions; fixed in 1.4.37
- bentoml (PyPI): affected all versions; fixed in 1.4.37

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33744/ (Markdown: https://insights.sbomify.com/CVE-2026-33744/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33744
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33744
- OSV: https://osv.dev/vulnerability/CVE-2026-33744

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33744/
Summaries are generated and may contain mistakes; the official description above is the record.
