CVE-2026-33749 n8n Vulnerable to XSS via Binary Data Inline HTML Rendering
Authenticated users can inject JavaScript via binary data, allowing attackers to execute code in victims' sessions and escalate privileges.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-33749?
CVE-2026-33749 is a medium-severity cross-site scripting vulnerability in N8n N8n, published on 25 Mar 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
n8n is an open source workflow automation platform. Prior to versions 1.123.27, 2.13.3, and 2.14.1, an authenticated user with permission to create or modify workflows could craft a workflow that produces an HTML binary data object without a filename. The `/rest/binary-data` endpoint served such responses inline on the n8n origin without `Content-Disposition` or `Content-Security-Policy` headers, allowing the HTML to render in the browser with full same-origin JavaScript access. By sending the resulting URL to a higher-privileged user, an attacker could execute JavaScript in the victim's authenticated session, enabling exfiltration of workflows and credentials, modification of workflows, or privilege escalation to admin. The issue has been fixed in n8n versions 1.123.27, 2.13.3, and 2.14.1. Users should upgrade to one of these versions or later to remediate the vulnerability. If upgrading is not immediately possible, administrators should consider the following temporary mitigations: Limit workflow creation and editing permissions to fully trusted users only, and/or restrict network access to the n8n instance to prevent untrusted users from accessing binary data URLs. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.
Weakness: CWE-79
Which versions are affected by CVE-2026-33749?
6 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 1.123.27 |
n8n npm | All versions | 1.123.27 |
n8n npm | From 2.0.0-rc.0 | 2.13.3 |
n8n npm | From 2.0.0-rc.0 | 2.13.3 |
n8n npm | From 2.14.0 | 2.14.1 |
n8n npm | From 2.14.0 | 2.14.1 |
Products include N8n N8n.
How do I fix CVE-2026-33749?
Upgrade n8n to a fixed version for your release line: 1.123.27, 2.13.3 or 2.14.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-33749 being exploited?
There is no known exploitation of CVE-2026-33749 in the wild and no public exploit code.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-qfc3-hm4j-7q77.