CVE-2026-33751 n8n Vulnerable to LDAP Filter Injection in LDAP Node
Attackers can inject LDAP filters in n8n workflows to read unauthorized data or bypass authentication if user input is passed to the LDAP node.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-33751?
CVE-2026-33751 is a medium-severity vulnerability in N8n N8n, published on 25 Mar 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
n8n is an open source workflow automation platform. Prior to versions 1.123.27, 2.13.3, and 2.14.1, a flaw in the LDAP node's filter escape logic allowed LDAP metacharacters to pass through unescaped when user-controlled input was interpolated into LDAP search filters. In workflows where external user input is passed via expressions into the LDAP node's search parameters, an attacker could manipulate the constructed filter to retrieve unintended LDAP records or bypass authentication checks implemented in the workflow. Exploitation requires a specific workflow configuration. The LDAP node must be used with user-controlled input passed via expressions (e.g., from a form or webhook). The issue has been fixed in n8n versions 1.123.27, 2.13.3, and 2.14.1. Users should upgrade to one of these versions or later to remediate the vulnerability. If upgrading is not immediately possible, administrators should consider the following temporary mitigations: Limit workflow creation and editing permissions to fully trusted users only, disable the LDAP node by adding `n8n-nodes-base.ldap` to the `NODES_EXCLUDE` environment variable, and/or avoid passing unvalidated external user input into LDAP node search parameters via expressions. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.
Weakness: CWE-90
Which versions are affected by CVE-2026-33751?
6 open source packages ship an affected version, including n8n. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
n8n npm | All versions | 1.123.27 |
n8n npm | All versions | 1.123.27 |
n8n npm | From 2.0.0-rc.0 | 2.13.3 |
n8n npm | From 2.0.0-rc.0 | 2.13.3 |
n8n npm | From 2.14.0 | 2.14.1 |
n8n npm | From 2.14.0 | 2.14.1 |
Products include N8n N8n.
How do I fix CVE-2026-33751?
Upgrade n8n to a fixed version for your release line: 1.123.27, 2.13.3 or 2.14.1.
Is CVE-2026-33751 being exploited?
There is no known exploitation of CVE-2026-33751 in the wild and no public exploit code.
Other vulnerabilities in N8n N8n
- CVE-2025-68613 n8n Improper Control of Dynamically-Managed Code Resources
- CVE-2026-21877 n8n is vulnerable to Remote Code Execution via Arbitrary File Write
- CVE-2026-21858 n8n Vulnerable to Unauthenticated File Access via Improper Webhook Request Handling
- CVE-2026-1470 n8n Unsafe Workflow Expression Evaluation Allows Remote Code Execution
- CVE-2025-68668 n8n Vulnerable to Arbitrary Command Execution in Pyodide based Python Code Node
Sources
Also known as GHSA-w83q-mcmx-mh42.