# CVE-2026-33757: OpenBao lacks user confirmation for OIDC direct callback mode


- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 27 Mar 2026
- **Updated:** 15 Jul 2026
- **Also known as:** BIT-openbao-2026-33757, GHSA-7q7g-x6vg-xpc3, GO-2026-4860

## What is CVE-2026-33757?

CVE-2026-33757 is a critical vulnerability in openbao, published on 27 Mar 2026. 

### Official description

OpenBao is an open source identity-based secrets management system. Prior to version 2.5.2, OpenBao does not prompt for user confirmation when logging in via JWT/OIDC and a role with `callback_mode` set to `direct`. This allows an attacker to start an authentication request and perform "remote phishing" by having the victim visit the URL and automatically log-in to the session of the attacker. Despite being based on the authorization code flow, the  `direct` mode calls back directly to the API and allows an attacker to poll for an OpenBao token until it is issued. Version 2.5.2 includes an additional confirmation screen for `direct` type logins that requires manual user interaction in order to finish the authentication. This issue can be worked around either by removing any roles with `callback_mode=direct` or enforcing confirmation for every session on the token issuer side for the Client ID used by OpenBao.

Weakness: CWE-384 (Session Fixation)

## Which versions are affected by CVE-2026-33757?

4 open source packages ship an affected version, including github.com/openbao/openbao and openbao. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20260325142553-e32103951925 |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20260325142553-e32103951925 |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20260325142553-e32103951925 |
| `openbao` | Bitnami | All versions | 2.5.2 |

Products: Openbao Openbao.

## How do I fix CVE-2026-33757?

Upgrade github.com/openbao/openbao to 0.0.0-20260325142553-e32103951925 or later.

## Is CVE-2026-33757 being exploited?

There is no known exploitation of CVE-2026-33757 in the wild and no public exploit code.

## Other vulnerabilities in openbao

- [CVE-2026-33758](https://insights.sbomify.com/CVE-2026-33758/): OpenBao has Reflected XSS in its OIDC authentication error message (critical 9.4)
- [CVE-2025-54997](https://insights.sbomify.com/CVE-2025-54997/): OpenBao: Privileged Operator May Execute Code on the Underlying Host (critical 9.1)
- [CVE-2025-64761](https://insights.sbomify.com/CVE-2025-64761/): OpenBao Privileged Operator Identity Group Root Escalation (high 7.5)
- [CVE-2025-59043](https://insights.sbomify.com/CVE-2025-59043/): OpenBao vulnerable to denial of service via malicious JSON request processing (high 7.5)
- [CVE-2025-54996](https://insights.sbomify.com/CVE-2025-54996/): OpenBao Root Namespace Operator May Elevate Token Privileges (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33757 and fix it if it is affected.

What it is: CVE-2026-33757 is a critical vulnerability in openbao, published on 27 Mar 2026. 
Exploitation: There is no known exploitation of CVE-2026-33757 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20260325142553-e32103951925
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20260325142553-e32103951925
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20260325142553-e32103951925
- openbao (Bitnami): affected all versions; fixed in 2.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33757/ (Markdown: https://insights.sbomify.com/CVE-2026-33757/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33757
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33757
- OSV: https://osv.dev/vulnerability/CVE-2026-33757

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33757/
Summaries are generated and may contain mistakes; the official description above is the record.
