# CVE-2026-33758: OpenBao has Reflected XSS in its OIDC authentication error message

> Reflected XSS in OpenBao OIDC error messages allows attackers to steal Web UI tokens when specific callback modes are enabled.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Mar 2026
- **Updated:** 15 Jul 2026
- **Also known as:** BIT-openbao-2026-33758, GHSA-cpj3-3r2f-xj59, GO-2026-4862

## What is CVE-2026-33758?

CVE-2026-33758 is a critical cross-site scripting vulnerability in openbao, published on 27 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

OpenBao is an open source identity-based secrets management system. Prior to version 2.5.2, OpenBao installations that have an OIDC/JWT authentication method enabled and a role with `callback_mode=direct` configured are vulnerable to XSS via the  `error_description` parameter on the page for a failed authentication. This allows an attacker access to the token used in the Web UI by a victim. The `error_description` parameter has been replaced with a static error message in v2.5.2. The vulnerability can be mitigated by removing any roles with `callback_mode` set to `direct`.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-20 (Improper Input Validation), CWE-116 (Improper Encoding or Escaping of Output)

## Which versions are affected by CVE-2026-33758?

4 open source packages ship an affected version, including github.com/openbao/openbao and openbao. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20260325133417-6e2b2dd84f0e |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20260325133417-6e2b2dd84f0e |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20260325133417-6e2b2dd84f0e |
| `openbao` | Bitnami | All versions | 2.5.2 |

Products: Openbao Openbao.

## How do I fix CVE-2026-33758?

Upgrade github.com/openbao/openbao to 0.0.0-20260325133417-6e2b2dd84f0e or later.

## Is CVE-2026-33758 being exploited?

There is no known exploitation of CVE-2026-33758 in the wild and no public exploit code.

## Other vulnerabilities in openbao

- [CVE-2026-33757](https://insights.sbomify.com/CVE-2026-33757/): OpenBao lacks user confirmation for OIDC direct callback mode (critical 9.6)
- [CVE-2025-54997](https://insights.sbomify.com/CVE-2025-54997/): OpenBao: Privileged Operator May Execute Code on the Underlying Host (critical 9.1)
- [CVE-2025-64761](https://insights.sbomify.com/CVE-2025-64761/): OpenBao Privileged Operator Identity Group Root Escalation (high 7.5)
- [CVE-2025-59043](https://insights.sbomify.com/CVE-2025-59043/): OpenBao vulnerable to denial of service via malicious JSON request processing (high 7.5)
- [CVE-2025-54996](https://insights.sbomify.com/CVE-2025-54996/): OpenBao Root Namespace Operator May Elevate Token Privileges (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-33758 and fix it if it is affected.

What it is: CVE-2026-33758 is a critical cross-site scripting vulnerability in openbao, published on 27 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-33758 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20260325133417-6e2b2dd84f0e
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20260325133417-6e2b2dd84f0e
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20260325133417-6e2b2dd84f0e
- openbao (Bitnami): affected all versions; fixed in 2.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-33758/ (Markdown: https://insights.sbomify.com/CVE-2026-33758/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-33758
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-33758
- OSV: https://osv.dev/vulnerability/CVE-2026-33758

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-33758/
Summaries are generated and may contain mistakes; the official description above is the record.
